Extension update doesn't work the first time on upgrade to 3.0

VERIFIED DUPLICATE of bug 424107

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 424107
10 years ago
10 years ago

People

(Reporter: Stijn Vermeeren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I develop a Firefox extension, 'Kotnet login'.

Version 0.4 (http://www.stijnvermeeren.be/download/kotnetlogin/kotnetlogin0.4.xpi) is compatible with Firefox 2.0.

Version 0.4.1 (http://www.stijnvermeeren.be/download/kotnetlogin/kotnetlogin0.4.1.xpi) is compatible with Firefox 3.0.

The update manifest is located at http://www.stijnvermeeren.be/download/kotnetlogin/update.rdf.

When I upgrade from Firefox 2.0 to 3.0rc4, and start Firefox 3.0 for the first time, I get a dialog box signalling Kotnet Login 0.4 as incompatible. I then ask to check for updates, and Firefox finds the 0.4.1 update. It downloads succesfully, and all seems right. But when I look in Tools -> Addons, there is still the old Kotnet Login 0.4, disabled because of incompatibility.

When I look in my profile folder under extensions/kotnetlogin@stijnvermeeren.be, there is the new version 0.4.1. But extensions.rdf mentions only the old 0.4 version (that has already been replaced).

Then I als in Tools -> Addons to check for updates. Again, the 0.4.1 update is found, installed, and when Firefox is restarted, the new 0.4.1 works fine.

It happens in Ubuntu and Windows XP.

So it seems like the extension updater that launches on the first run of Firefox 3.0, does correctly installs my new extension, but does not update extensions.rdf and maybe other relevant files.

Reproducible: Always

Steps to Reproduce:
1. Install Kotnet Login 0.4 on Firefox 2.0
2. Upgrade to Firefox 3.0
3. Start Firefox 3.0, check for extension updates and install Kotnet Login 0.4.1
4. Look in Tools -> Addons
5. Check for addon updates, install Kotnet Login 0.4.1 and restart Firefox
6. Look again in Tools -> Addons
Actual Results:  
in step 4. Kotnet Login is still in version 0.4 and disabled
only in step 6. the addon is in version 0.4.1 and enabled again

Expected Results:  
already in step 4. Kotnet Login should be in version 0.4.1 and enabled

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424107

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.