Broken auto-complete, nsIAutoCompleteController.input failure

RESOLVED FIXED in Firefox 3

Status

()

Firefox
Address Bar
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Paul-Kenji Cahier, Assigned: Mardak)

Tracking

({regression})

Trunk
Firefox 3
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 413836])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040202 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040202 Minefield/3.0pre

I have not yet been able to find the cause but since around the 01/04 build I've been experiencing auto-complete issues causing the urlbar to be completly disabled.
The following error then appears when anything happens in the urlbar:
Error: uncaught exception: [Exception... "Component does not have requested interface arg 0 [nsIAutoCompleteController.input]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: attachController :: line 271"  data: no]

This might be related(or not) to the following errors that do appear too:
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml ::  :: line 644"  data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 650


Reproducible: Sometimes

Steps to Reproduce:
Could not reproduce so far as I have not been able to identify when this occurs.
Actual Results:  
URLbar will not accept to load any url anymore.

Expected Results:  
URLbar should continue to work.

Could be related to https://bugzilla.mozilla.org/show_bug.cgi?id=418243 which is marked as mac only.
Confirming, I see this using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre. I see a similar issue as described in Comment 0, suddenly I hit enter in the URL bar to submit and it doesn't work. Will try to get a set of STR.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

10 years ago
Some additional information:
I have noticed that once the situation occurs, and the urlbar is more or less useless, one thing that *sometimes* fixes it is loading an https page(so that the top display changes to the https look) then browsing back to a normal http page.(Typically opening that bugzilla entry, and then clicking to the normal http link to mozilla.org on top right)
I have not been able to reproduce it everytime but sometimes it works.
(Assignee)

Comment 3

10 years ago
Potentially caused by bug 413836?
(Reporter)

Comment 4

10 years ago
If so, what about fixing this by catching any error from the attach?
(Though I guess that would not be a solution)
(Assignee)

Comment 5

10 years ago
Do you see the problem with this build?

https://build.mozilla.org/tryserver-builds/2008-04-05_02:17-edward.lee@engineering.uiuc.edu-urlbar/
Assignee: nobody → edilee
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 413836
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [fixed by bug 413836]
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
(Assignee)

Comment 6

10 years ago
The original patch from bug 413836 was replaced with another fix which shouldn't cause this anymore.
Keywords: regression
You need to log in before you can comment on or make changes to this bug.