Quick Find steals focus on close

RESOLVED DUPLICATE of bug 332990

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 332990
10 years ago
10 years ago

People

(Reporter: Greg Valure, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Firefox 2.0.0.13 on Windows XP:

- Close all Firefox windows.
- Open Firefox either by opening a Windows web shortcut or by starting Firefox when you have a home page defined.  It will not work if you start Firefox and it's set to start with a blank window.
- Start typing to activate Quick Find.
- Switch to something else, such as by Alt-Tab.
- When the quick find bar disappears in a few seconds, Firefox will steal the focus back.

This only seems to happen the first time, as in subsequent attempts it will leave the focus alone.  It also doesn't work if you start with a blank page because giving focus to the URL bar before doing this seems to correct it.  It looks like something just isn't initialized correctly but eventually it will get into the correct state.

As to how this applies in the real world, I hit it all the time because I open our staff telephone directory from a link, start typing in someone's same, and then switch to something else once I have their extension.
Seems a dupe of Bug 332990.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332990
(Reporter)

Updated

10 years ago
No longer blocks: 88810
You need to log in before you can comment on or make changes to this bug.