Investigate why the mochitest for bug 392746 is failing on linux (and try to fix it)

RESOLVED FIXED

Status

()

Core
Selection
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: Ginn Chen)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

2.61 KB, patch
Martijn Wargers (zombie)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
The mochitest for bug 392746 was disabled for Linux, because it failed on the Linux tinderbox.

I guess it's failing there, because the wrong text is being selected or something.
Anyhow, this needs to be investigated and fixed, so that this test also works on Linux.
Component: Testing → Selection
QA Contact: testing → selection
In the meantime,
{
*** 43863 INFO Running /tests/layout/generic/test/test_bug392746.html...
*** 43864 INFO TEST-KNOWN-FAIL | /tests/layout/generic/test/test_bug392746.html | [SimpleTest.report()] No checks actually run.
}
No longer blocks: 483407
Depends on: 483407
(Assignee)

Comment 3

9 years ago
The test case failed on Solaris if I build Firefox 3.5 with system cairo library.
But it doesn't fail if I use mozilla internal cairo.
Weird.
After the failure, the mouse cursor looks like some text is being dragged.
And then hundreds of cases are timeout because Firefox couldn't grab the focus.
(Assignee)

Comment 4

8 years ago
Created attachment 442354 [details] [diff] [review]
patch

I think the root cause of this bug is the text somehow wrapped in the mochitest window.
i.e.
text ccc text text text eee text text text text text bbb
text

I removed some texts and hope it will not wrap.

I will send it to try server to confirm.
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #442354 - Flags: review?(martijn.martijn)
(Reporter)

Comment 5

8 years ago
Comment on attachment 442354 [details] [diff] [review]
patch

> I think the root cause of this bug is the text somehow wrapped in the mochitest
window.
But why does this happen only on linux? I guess the font is a little bit bigger there or something?

-  wu.sendMouseEvent('mouseup',  aY2, aY2, 0, 1, modifyers);
+  wu.sendMouseEvent('mouseup',  aX2, aY2, 0, 1, modifyers);
What is changed here? Nothing it seems.

Anyway, if this fixes the test for linux, then that's great!
Thanks for fixing!
Attachment #442354 - Flags: review?(martijn.martijn) → review+
(Assignee)

Comment 6

8 years ago
From try server results, it fixed the problem.

I changed (aY2, aY2) to (aX2, aY2).
It is meaningless for mouseup event, I think.
But (aY2, aY2) doesn't make sense to me.
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/0ada8755f63c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.