Last Comment Bug 426679 - A "Redirect Notice" appears when clicking nearly any Google search result
: A "Redirect Notice" appears when clicking nearly any Google search result
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.google.com/search?hl=en&q=...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 20:12 PDT by Jim
Modified: 2011-08-05 22:28 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jim 2008-04-02 20:12:12 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

After visiting google.com and searching for a term, clicking on nearly any search result takes you to a page with the following text:
================
*Redirect Notice*

 The previous page is sending you to _http://digg.com/_.

 If you do not want to visit that page, you can _return to the previous page_.
================

I suppose this is intended to fight Phishing redirection attacks, but as of Firefox 3 Beta 5, the Redirect Notice is shown for all search results, including clearly non-phishing results such as digg.com and yahoo.com.

This does not occur in:
Firefox 2.0.0.13
Firefox 3 Beta 4
Internet Explorer 7

Reproducible: Always

Steps to Reproduce:
1. Visit http://google.com
2. enter the search term: yahoo
3. click the first result (should be Yahoo! aka www.yahoo.com)
Actual Results:  
You arrive at a Redirect Notice page instead of www.yahoo.com. You may click through to yahoo.com or click to go to the previous page (the search results page).

The URL of the redirect notice page is: http://www.google.com/url?sa=t&ct=res&cd=1&url=http%3A%2F%2Fwww.yahoo.com%2F

Expected Results:  
It should have taken me to http://www.yahoo.com, since http://yahoo.com is clearly not a phishing site.

I suspect that google's javascript for Firefox 3 Beta 5 is triggering google's own phishing protection, possibly due to google's javascript url rewriting (which is described in Bug 229050).

This also occurs with other non-phishing results, such as clicking the first results for "digg" or "microsoft corporation" google searches.
Comment 1 Reed Loden [:reed] (use needinfo?) 2008-04-02 20:25:30 PDT
This has nothing to do with Firefox... Google is doing this.
Comment 2 Jim 2008-04-02 20:42:36 PDT
I realize it looks like a problem with google and not with Firefox.  But, it only occurs with Firefox 3 Beta 5. It didn't occur with Firefox 3 Beta 4, or with Firefox 2.0.0.13.

So, could it really be the case that Google is doing this specifically when it detects that Firefox 3b5 is being used?  Or perhaps it is due to a change in how Firefox 3 Beta 5 deals with Google's onclick method of redirection? 

Re-opening log hoping you agree... not trying to beat this into the ground, I just want to make sure it's not due to a Firefox change.
Comment 3 Jim 2008-04-02 21:21:05 PDT
Also, it only occurs when you are logged into a google account.
Comment 4 m 2008-04-02 21:22:43 PDT
It is important to note it only occurs when signed into your Google Account.

At least it does with me and several others from here :: 

http://www.gamerswithjobs.com/node/38466

I am on Windows XP. Again, this doesn't happen with Internet Explorer.

A combination of FireFox 3 Beta 5 + Google Account.
Comment 6 Jesse Ruderman 2008-04-02 21:53:51 PDT
Maybe you're spoofing your referrer header, and Google interprets that as meaning you're not coming from the Google search results page when you load the search-result-click-tracking URL?

Can you guys still reproduce after creating a fresh Firefox profile and logging into a Google account?
Comment 7 m 2008-04-02 22:10:57 PDT
Good call.

When I try a new profile it works fine...!
Comment 8 m 2008-04-02 22:12:04 PDT
Are there changes I can make to my current default profile that will allow me to resolve the bug? Or should I just go with a new profile?
Comment 9 Jesse Ruderman 2008-04-02 22:30:45 PDT
It would be great if you could figure out what in your profile triggers the bug.  (I can't do that myself, since I don't see the bug at all.)  One way to do that is to copy files one at a time into your new profile (while Firefox isn't running) and see when the bug reappears.  That would help us figure out whether it's a Firefox bug, and if so, how to fix it.
Comment 10 m 2008-04-02 22:33:09 PDT
Ah, I just deleted my old profile literally like 3 minutes ago out of frustration.

Hopefully someone else in this thread can do that though!
Comment 11 [:Cww] 2008-04-02 23:46:44 PDT
Try clearing your Google cookies.  I know that Google redirects you around based on the contents of those and I guess if they get corrupted it goes wonky.
Comment 12 Jim 2008-04-03 08:09:51 PDT
I was unable to reproduce this on my XP computer, which had been using 3beta4 previously. I didn't clear any cookies. I closed 3beta4, installed 3beta5, launched it, went to google.com (I was logged into my google account from my previous session/cookie), and searched for digg, and was able to click on the first result without a redirect notice appearing.
Comment 13 Asa Dotzler [:asa] 2008-04-03 22:20:48 PDT
I'm unable to reproduce this and I suspect that people who were (disproportionately SEO SEM folks, based on the blogs talking about it) had some Firefox add-on or pref setting that was causing this to happen.

This isn't a phishing protection (the Firefox feature) issue as far as I can tell. Neither is it "major" severity. Most likely it's not even a Firefox bug and probably should belong to Google or some SEO-related extension author. 
Comment 14 Jim 2008-04-04 07:16:13 PDT
Okay, I'm marking this as closed/invalid. 

As mentioned above, perhaps it was a leftover Google cookie. Although it had been happening consistently at the time, I'm currently unable to reproduce it on the Vista computer in the initial description. Perhaps a cookie expired, or something was changed by Google.

Thanks to everyone who helped look into this.

Note You need to log in before you can comment on or make changes to this bug.