Status

()

defect
P2
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: kaie, Assigned: kaie)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

572 bytes, patch
rrelyea
: review+
Details | Diff | Splinter Review
Assignee

Description

11 years ago
We want to deliver a NSS 3.12 release candidate snapshot for Firefox 3 RC 1.
Flags: blocking1.9?
Assignee

Comment 1

11 years ago
We must decide on a name for the snapshot.
Shall it be Beta 4 or RC 1?
Should the NSS snapshot identify itself as a beta or as a release candidate?

Wan-Teh, please feel free to propose an updated NSPR tag at the same time.

This bug depends on adding the new roots that we want to get into FF3, bug 425469.

This one blocks bug 425518.


Blocks: 425518
Depends on: 425469
Assignee

Comment 2

11 years ago
We have decided to call it RC1 and have it identify itself as a release, not a beta.
We want to try to resolve bug 400238 and bug 303457 before RC1.
Depends on: 303457, 400238
Why would creating a NSS snapshot block the release of Firefox 3?

Seems like no matter what, Firefox 3 will ship with _some_ version of NSS regardless of what it's called, right? 

-'ing this, but if what you are trying to say is that Firefox 3 must have a new version of NSS for us to ship (or some other reason that's different from my interpretation above), then please re-nom.  :)
Flags: blocking1.9? → blocking1.9-
(In reply to comment #4)
> -'ing this, but if what you are trying to say is that Firefox 3 must have a new
> version of NSS for us to ship (or some other reason that's different from my
> interpretation above), then please re-nom.  :)

Firefox 3 must have a new version of NSS for bugs like bug 425518 and other NSS issues.
Flags: blocking1.9- → blocking1.9?
(In reply to comment #5)
> (In reply to comment #4)
> > -'ing this, but if what you are trying to say is that Firefox 3 must have a new
> > version of NSS for us to ship (or some other reason that's different from my
> > interpretation above), then please re-nom.  :)
> 
> Firefox 3 must have a new version of NSS for bugs like bug 425518 and other NSS
> issues.
> 

OK.  This makes sense.  Thanks for the explanation.  Blocking.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2

Comment 7

11 years ago
Version of NSS changed to NSS 3.12.0.0 to prepare NSS 3.12 RC1.

Checking in manifest.mn;
/cvsroot/mozilla/security/nss/manifest.mn,v  <--  manifest.mn
new revision: 1.20; previous revision: 1.19
done
Checking in lib/nss/nss.h;
/cvsroot/mozilla/security/nss/lib/nss/nss.h,v  <--  nss.h
new revision: 1.55; previous revision: 1.54
done
Checking in lib/softoken/softkver.h;
/cvsroot/mozilla/security/nss/lib/softoken/softkver.h,v  <--  softkver.h
new revision: 1.3; previous revision: 1.2
done

Assignee

Comment 8

11 years ago
Note that bug 425469 has been fixed for NSS 3.12.
(The bug is being kept open for landing on another branch)
Assignee

Comment 9

11 years ago
Posted patch Patch v1 (obsolete) — Splinter Review
Attachment #314050 - Flags: review?(rrelyea)

Comment 10

11 years ago
Comment on attachment 314050 [details] [diff] [review]
Patch v1

r+ rrelyea
Attachment #314050 - Flags: review?(rrelyea) → review+
Assignee

Comment 11

11 years ago
checked in, marking fixed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Assignee

Comment 12

11 years ago
I have to reopen this bug, because I had to revert Mozilla to the previous beta3 tag.

The landing of RC1 caused bug 427706.
Status: RESOLVED → REOPENED
Depends on: 427706
Resolution: FIXED → ---
Assignee

Comment 13

11 years ago
Posted patch Patch v2Splinter Review
We've backed out the patch that caused the regression.
Attachment #314050 - Attachment is obsolete: true
Attachment #314394 - Flags: review?(rrelyea)

Comment 14

11 years ago
Comment on attachment 314394 [details] [diff] [review]
Patch v2

r+
Attachment #314394 - Flags: review?(rrelyea) → review+
Assignee

Comment 15

11 years ago
changing subject to RC2
Summary: FF3RC1 should use NSS_3_12_RC1 → FF3RC1 should use NSS_3_12_RC2
Assignee

Comment 16

11 years ago
checked in again

This time it looks good, the machine the reported the failure yesterday has now passed a full cycle with green.

Marking fixed again.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.