Last Comment Bug 426739 - Three-finger navigation gestures on MacBook Pro trackpads should be recognized
: Three-finger navigation gestures on MacBook Pro trackpads should be recognized
Status: RESOLVED FIXED
: fixed1.8.1.14
Product: Camino Graveyard
Classification: Graveyard
Component: OS Integration (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- enhancement (vote)
: Camino1.6
Assigned To: Stuart Morgan
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 03:22 PDT by Ansgar Esztermann
Modified: 2008-11-30 04:59 PST (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix (2.47 KB, patch)
2008-04-03 12:34 PDT, Stuart Morgan
mikepinkerton: superreview+
Details | Diff | Splinter Review

Description Ansgar Esztermann 2008-04-03 03:22:07 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.13) Gecko/20080327 Camino/1.6b4 (like Firefox/2.0.0.13)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.13) Gecko/20080327 Camino/1.6b4 (like Firefox/2.0.0.13)

The new MacBook Pro models support three-finger gestures. These are for "navigation"; in Safari, they will move back/forward one page in the browser's history. 
Implementing this in Camino would both enhance the browser's integration into the OS, and speed up navigation on computers that are equipped with the new trackpads.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Stuart Morgan 2008-04-03 06:52:39 PDT
Which makes it a shame that Apple has withheld any API related to the new gestures, so that only Apple's applications can legitimately use them.

We could consider doing this now with the reverse-engineered methods if it's not enough code that potentially having to re-write in when a real API comes out wouldn't be an issue.
Comment 2 Smokey Ardisson (offline for a while; not following bugs - do not email) 2008-04-03 07:58:11 PDT
We'd also have to hope that Core doesn't do anything in bug 412486 that will break anything we might do :p
Comment 3 Stuart Morgan 2008-04-03 12:34:44 PDT
Created attachment 313409 [details] [diff] [review]
fix

Supports back/forward and page up/down through swipe gestures.
Comment 4 Mike Pinkerton (not reading bugmail) 2008-04-03 12:38:36 PDT
Comment on attachment 313409 [details] [diff] [review]
fix

sr=pink
Comment 5 Stuart Morgan 2008-04-03 12:54:01 PDT
Landed on trunk and MOZILLA_1_8_BRANCH (we slipped it in for 1.6 since it's extremely low-risk).

Now I just need a MacBook Air...
Comment 6 Daniel Veditz [:dveditz] 2008-04-03 20:00:53 PDT
-> fixed1.8.1.15, the 1.8.1.14 release is going to come from a _RELBRANCH
Comment 7 Mark Mentovai 2008-04-09 14:29:26 PDT
<- fixed1.8.1.15; Camino 1.6 is based on that relbranch.

Note You need to log in before you can comment on or make changes to this bug.