md build broken in xpcom/libxpt/tests/

VERIFIED FIXED in M12

Status

()

P3
major
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: akkzilla, Assigned: akkzilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 3/25/99 waiting to hear back from reporter)

(Assignee)

Description

20 years ago
The SIMPLE_PROGRAMS rule is broken so that when multiple programs are specified
in a Makefile, the depend build breaks because .deps is one of the dependencies.
I'm about to check in a fix.

Eventually you might want to think about putting this directory under
--enable-tests (but since --enable-tests is badly broken now, I can understand
not wanting to put it there if this test actually works :-)
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

20 years ago
Fix checked in.

Updated

20 years ago
Whiteboard: 3/25/99 waiting to hear back from reporter

Comment 2

20 years ago
Akkana how can I verify this fix?
(Assignee)

Comment 3

20 years ago
Sar asked me to file it -- maybe she can verify it once the next builds
complete?  What's the procedure on build-bustage bugs?

Comment 4

20 years ago
if the tinderbox build running --enable-md (fathom) turns green then this fix
will be verified.

We're not there yet.

Akkana, should I start with a clean tree?
(Assignee)

Comment 5

20 years ago
No, you shouldn't need to clobber or start with a clean tree.  But the fathom
error now is a different one, in webshell/tests/viewer/nsImageInspectorDialog,
which is a new problem.

Updated

20 years ago
QA Contact: 3849 → 3796

Comment 6

20 years ago
Sarah, when you check out the build, and you verify this, please mark it
verified -- I'm setting you as QA contact.

Comment 7

19 years ago
marking this verfied and setting milestone so it gets off the no TM setting
Status: RESOLVED → VERIFIED
Target Milestone: --- → M12
You need to log in before you can comment on or make changes to this bug.