May open wrong file if two files have been downloaded whose names differ only in capitalization.

VERIFIED DUPLICATE of bug 301328

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 301328
10 years ago
10 years ago

People

(Reporter: Jan Reineke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

I downloaded the following couple of files:

http://www.computer.org/portal/cms_docs_ieeecs/ieeecs/publications/author/transguide/ieeetran_howto.pdf
http://ras.papercept.net/conferences/support/files/IEEEtran_HOWTO.pdf

Their names differ only in capitalization. 
After closing both of the files. I clicked on the latter in the list of downloads. Unfortunately, this opened the former!

Reproducible: Always

Steps to Reproduce:
1. Download http://www.computer.org/portal/cms_docs_ieeecs/ieeecs/publications/author/transguide/ieeetran_howto.pdf
2. Download http://ras.papercept.net/conferences/support/files/IEEEtran_HOWTO.pdf
3. Try to open IEEEtran_HOWTO.pdf through the Downloads window. 
Actual Results:  
It opens "ieeetran_howto.pdf".

Expected Results:  
It should open "IEEEtran_HOWTO.pdf".

Updated

10 years ago
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 301328
verified dupe
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.