Closed Bug 426808 Opened 12 years ago Closed 12 years ago

Report Broken Website dialog broken

Categories

(Other Applications Graveyard :: Reporter, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 425814

People

(Reporter: adam, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I tried to report a broken website, but the dialog that came up was in an incorrect state. I have a screen shot available.

Reproducible: Always

Steps to Reproduce:
1. Click "Help", "Report Broken Web Site..."
Actual Results:  
The dialog that comes up is the Privacy Policy step, with no actual text of the policy, and the Back button disabled. The previous steps of this wizard, where a description of the problem can be entered, is never shown, and the Back button is disabled.

Expected Results:  
The dialog should show the first page of the wizard, which allows (as I recall) the user to describe the problem. Also, when the wizard reaches the final page, the privacy policy text should not be blank.

It's possible the privacy policy text is not initialized because the wizard started on the wrong page, and that initialization might be triggered when the "Next" button is clicked from the previous page.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Component: Menus → Reporter
Product: Firefox → Webtools
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 425814
Product: Webtools → Other Applications
QA Contact: menus → xul-client
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.