Closed Bug 426896 Opened 17 years ago Closed 17 years ago

Right Click on <input> elements does not invoke Context Menu

Categories

(Firefox :: Extension Compatibility, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 424101

People

(Reporter: patrickf, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5


When viewing an Amazon product page when right clicking on the "Add To Shopping Cart" the context menu is not invoked.  

I believe this has to deal with the <input> element and the focus of the browser on the element which bypasses the opportunity to add contextual options to the page.  

no context menu features are available for the image being clicked on. 


Reproducible: Always

Steps to Reproduce:
1. Go to: http://www.amazon.com/gp/product/1934454079/ref=s9mgif_c2_img3-rfc_g1-2814_p?pf_rd_m=ATVPDKIKX0DER&pf_rd_s=center-2&pf_rd_r=0S58R8M3DRY3BSWMQY77&pf_rd_t=101&pf_rd_p=329355401&pf_rd_i=507846

2. Place mouse over the "Add to Shopping Cart"

3. Right Click
Actual Results:  
The context menu does not appear.  The image is highlighted. 

Expected Results:  
I expect that the context menu will appear the registered context menu extensions will be called at and that onImage will be set.  

I think this is a major bug due to the fact that right-click is a basic browser fundamental feature.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.