Progam fails to complete install because UAC password prompting is not activated

VERIFIED DUPLICATE of bug 404541

Status

()

Firefox
Installer
VERIFIED DUPLICATE of bug 404541
10 years ago
10 years ago

People

(Reporter: Jan Goosen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Problem occurs
* under Windows Vista Ultimate Service Pack 1. Unsure if it happens with another version or non-SP1 version.
* when installing under a limited user account by double clicking the FF3b5 intall file
* Install fails to proceed with the message "You don't have access to write to the installation directory. Click okay to select a different directory."



Reproducible: Always

Steps to Reproduce:
1. Run Windows Vista Ultimate SP1 as a Limited User – most sensible way to run Vista on a day-to-day basis
2. Double click  FF3b5 install file
3. Series of windows appears as follows:
  a. "Do you want to run this file ..."
  b. "Welcome to FireFox 3 Beta 5 Setup Wizard ..."
  c. "License Agreement" - I checked 'Accept'
  d. "Setup Type ..." - I selected 'Typical'
  e. "Choose install location ..." - I left it as the default C:\Program
      Files\FireFox Beta 5\
4. At this point I selected "Next"
5.  Message displayed "You don't have access to write to the installation directory. Click ojkay to select a different directory."
6.  Unable to proceed further and had to quit at this point.
7. Subsequently able to install successfully by running the install file under elevated privileges:
  a. Right click
  b. "Run as administrator"
Actual Results:  
1. Message displayed "You don't have access to write to the installation directory. Click ojkay to select a different directory."
2.  Unable to proceed further and had to quit at this point.


Expected Results:  
This is my experience installing other programs in a limited user account...
1. Double click install file
2. Windows would probably allow the files to unpack
3. Shortly after unpack, would expect the screen to dim and see a prompt "Windows needs your permission to continue"
4. Enter an administrator's password
5. Install would continue uninterrupted by UAC.

This bug occurs on a PC with a benign Windows Vista Ultimate installation. SP1 and all updates to Vista have been installed.

I normally run WIndows Vista under a Limited User Acount because it is the most secure way of running this computer for day to day use - prevents my kids from playing around with the installation

I think this is a reasonably important bug, because it may deter users from installing what is otherwise shaping up to be a fine browser.

Sorry if this is a repeat of an existing report

Jan
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404541

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.