If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The parser ignores lots of tags...

VERIFIED DUPLICATE of bug 42312

Status

()

Core
HTML: Parser
P3
critical
VERIFIED DUPLICATE of bug 42312
18 years ago
17 years ago

People

(Reporter: jst, Assigned: rickg)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Not sure how to put this, but it looks like that parser drops a whole lot of
tags nowadays on some pages, you can see this on at least the following sites:

  http://www.w3.org/TR/REC-CSS2/
    the toc is just a big mess, i.e. not nicely formatted

  http://www.w3.org/TR/DOM-Level-2/core.html
  http://www.w3.org/TR/DOM-Level-2/html.html
  http://www.w3.org/TR/DOM-Level-2/css.html
    most of the interface definitions are missing the grey background

  http://www.w3.org/TR/1998/REC-xml-19980210
    most of the formatting of the text is lost

  http://www.hex.fi/eng/marketinfo/index_stock.html
    last table not displayed as a table

I checked this out somewhat and it looks like the problem is that the parser
simply doesn't give all the necessary elements to the content sink...

Not sure what's common to all these pages but IMO this is not acceptable for
beta2. I have a few simplified testcases that I'll attach.
(Reporter)

Updated

18 years ago
Keywords: nsbeta2
(Reporter)

Comment 1

18 years ago
Created attachment 10193 [details]
Simplified DOML2 core spec
(Reporter)

Comment 2

18 years ago
Created attachment 10194 [details]
Simplified version of the hex.fi page.
Both attachements have in common the fact that they are correctly missing an 
optional </P> but StrictDTD doesn't accept that yet.

This is a DUP of several bugs, the most recent one I found is bug 42312.

Not marking DUP; when that bug is fixed I think this should be rechecked.
Depends on: 42312
(Reporter)

Comment 4

18 years ago
Yup, looks like this is a dup, here's one more page to check once bug 42312 is
fixed.

  http://www.w3.org/TR/1998/REC-html40-19980424/index/attributes.html
(Assignee)

Comment 5

18 years ago
This is a dup of 42312, and is fixed in my tree. In fact, in most cases mozilla 
looks *FAR* better than navigator on these pages (look at the stock market 
example). 

*** This bug has been marked as a duplicate of 42312 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Whiteboard: fix in hand
(Reporter)

Comment 6

18 years ago
Yes, I agree, Navigator didn't event come close mozilla on any of the mentioned
URL's before this regression, looking forward to your fix...

Comment 7

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.