Closed Bug 427034 Opened 13 years ago Closed 13 years ago

Crash/Error Reporter, Email field not disabled after submission

Categories

(Toolkit :: Crash Reporting, defect)

Other
Windows Vista
defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: david.maza.AU, Assigned: timeless)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

After a crash in Mozilla Firefox, you are taken to the crash reporter. While you're submitting a crash you are able to click inside the email field and edit it despite it being grayed out.

Reproducible: Always

Steps to Reproduce:
1. Create a crash in Firefox
2. Input the details and click Restart Firefox, the crash will be submitted
3. You are able to click inside the email field and edit it while it's submitting, the field should be disabled/grayed out so that users are unable to change the email field while it's submitting. The description is disabled but the email field is not.
Component: General → Breakpad Integration
Product: Firefox → Toolkit
QA Contact: general → breakpad.integration
Version: unspecified → Trunk
Anyone?
Attached patch this might work (obsolete) — Splinter Review
Assignee: nobody → timeless
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #315354 - Flags: review?(ted.mielczarek)
Whiteboard: [needs review]
Comment on attachment 315354 [details] [diff] [review]
this might work

This isn't going to work. The relevant bits are here:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/crashreporter/client/crashreporter_win.cpp&rev=1.28#1108
Attachment #315354 - Flags: review?(ted.mielczarek) → review-
Any status on this issue?
Whiteboard: [needs review]
fwiw SetDlgItemDisabled is unused (which is very confusing)
Attachment #315354 - Attachment is obsolete: true
Attachment #319260 - Flags: review?(ted.mielczarek)
Whiteboard: [needs review]
Is there a possibility for this to be fixed in RC2 or will it be delayed till 4.0?
It's not really that big of a deal. I doubt I'd bother trying to land it if we have an RC2. We can probably get it into a 3.0.x release.
Comment on attachment 319260 [details] [diff] [review]
this is more likely to work

That looks reasonable, although I haven't tested it. Maybe spin a try server build for testing? Should be ok to land this in mozilla-central, and then ask for approval1.9 to get it into 1.9.0.1.
Attachment #319260 - Flags: review?(ted.mielczarek) → review+
Hardware: PC → Other
Whiteboard: [needs review] → [needs trybuild]
Any progress on this bug?
David: if you can test that build that Tomcat linked in the previous comment to ensure that the bug is fixed there, we can get this patch landed. All our work is done here in bugzilla, so if you don't see any activity, then nothing has happened in the bug.
Anyway to force a crash in Vista? I've tried:

http://ted.mielczarek.org/code/mozilla/crashme.xpi

But it takes me the standard Microsoft Error Reporting Utility in Windows Vista.
Oh, since that's not an official build, you may need to edit application.ini in a text editor and add Enabled=1 below [Crash Reporter]
I've already checked before I posted the comment and 'Enabled' has already been declared in application.ini and is set to 1.
I finally managed to get it working after doing a registry tweak that disabled Error Reporting and DEP completely.

The tryserver build fixes the bug. Confirmed.
Thanks. We'll get this landed in mozilla-central when that opens for general checkins.
Any chance of getting this into mozilla-central soon so that it can make Firefox 3.0.0?
This could land in mozilla-central at any time. It won't make Firefox 3.0, but it's possible that we could land it on the branch for 3.0.1 or another security release.
timeless: this can land in m-c. I can land it for you if you'd like.
Any chance of getting it landed soon?
fixed in 16272:d272312ac39f
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.