Closed Bug 427060 Opened 13 years ago Closed 12 years ago

Get Error during XSLT transformation: Waiting for …

Categories

(Core :: XSLT, defect, P3)

1.9.0 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.1a2

People

(Reporter: george, Assigned: peterv)

References

()

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

The supplied url fails in firefox 3 beta 3 through 5.  It works in firefox 2.

I built the page just for you guys, so if you have trouble getting to it let me know & I can just send you the files.

Reproducible: Always

Steps to Reproduce:
1.go to http://www.nottheworst.com/p/bookmarks.xml
2.
3.
Actual Results:  
Error during XSLT transformation: Waiting for …

Expected Results:  
a list of bookmarks with directories that open & close

It works in safari too.
This was caused on 8 Sep 2006 probably by Bug 324092.
Blocks: 324092
Duplicate of this bug: 441151
confirming based on dupe
Status: UNCONFIRMED → NEW
Component: General → XSLT
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → xslt
Version: unspecified → 1.9.0 Branch
Assignee: nobody → jonas
Flags: wanted1.9.0.x+
Keywords: regression
OS: Mac OS X → All
Priority: -- → P1
Hardware: Macintosh → All
Just checking the status of this bug.  Looks like it is still unresolved.
I am a relative newbie to this list.  What is the procedure for fixing bugs like this one?
Someone needs to analyze this issue, write a patch, get reviews and commit this to CVS. After that the bug status of this bug get changed from NEW to "fixed"
Attached patch v1 (obsolete) — Splinter Review
Assignee: jonas → peterv
Status: NEW → ASSIGNED
Attachment #331367 - Flags: superreview?(jonas)
Attachment #331367 - Flags: review?(jonas)
Priority: P1 → P3
Target Milestone: --- → mozilla1.9.1a2
Comment on attachment 331367 [details] [diff] [review]
v1

>diff --git a/content/xslt/src/xslt/txMozillaXMLOutput.cpp b/content/xslt/src/xslt/txMozillaXMLOutput.cpp
>--- a/content/xslt/src/xslt/txMozillaXMLOutput.cpp
>+++ b/content/xslt/src/xslt/txMozillaXMLOutput.cpp
>@@ -806,14 +806,15 @@ txMozillaXMLOutput::endHTMLElement(nsICo
>         nsAutoString value;
>         aElement->GetAttr(kNameSpaceID_None, txHTMLAtoms::target, value);
>         doc->SetBaseTarget(value);
> 
>-        aElement->GetAttr(kNameSpaceID_None, txHTMLAtoms::href, value);
>-        nsCOMPtr<nsIURI> baseURI;
>-        rv = NS_NewURI(getter_AddRefs(baseURI), value, nsnull);
>-        NS_ENSURE_SUCCESS(rv, rv);
>+        if (aElement->GetAttr(kNameSpaceID_None, txHTMLAtoms::href, value)) {
>+            nsCOMPtr<nsIURI> baseURI;
>+            rv = NS_NewURI(getter_AddRefs(baseURI), value, nsnull);
>+            NS_ENSURE_SUCCESS(rv, rv);
> 
>-        doc->SetBaseURI(baseURI); // The document checks if it is legal to set this base
>+            doc->SetBaseURI(baseURI); // The document checks if it is legal to set this base
>+        }

We don't really want to abort the transformation just because the attribute is specified but invalid, do we? Maybe just call SetBaseURI if a URI was successfully created, and ignore otherwise?
Attached patch v1.1Splinter Review
Attachment #331367 - Attachment is obsolete: true
Attachment #331389 - Flags: superreview?(jonas)
Attachment #331389 - Flags: review?(jonas)
Attachment #331367 - Flags: superreview?(jonas)
Attachment #331367 - Flags: review?(jonas)
Attachment #331389 - Attachment is patch: true
Attachment #331389 - Attachment mime type: application/octet-stream → text/plain
Attachment #331389 - Flags: superreview?(jonas)
Attachment #331389 - Flags: superreview+
Attachment #331389 - Flags: review?(jonas)
Attachment #331389 - Flags: review+
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.