Opening a link with custom application: The chosen application is not preserved

RESOLVED INCOMPLETE

Status

()

Firefox
File Handling
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Jari Aalto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Opening a link whose media type is not known or text file containing 
control characters, a pop up "What should firefox do with this file" appears.

[x] Open with => Select "
[x] Do this automatically for files ...

[OK]

Reproducible: Always

Steps to Reproduce:
1. Select link (see "Details")
2. Select custom application (See "Details")
3. Press [OK] button (See "Details")


Repeat the above for same link. At stage 2, all questions are asked again and
the previously selected application is not used or preserved although
checkbox "[x] Do this automatically" was chosen.

See picture: steps 1, 2, 3 to select Win2000 / WINNT / System32 / dllcache / Wordpad application as default for *.txt files that contain control characters.

 
Actual Results:  
Previous state is not preserved.
(Reporter)

Comment 1

10 years ago
Created attachment 313633 [details]
Dialog 1

Dialog: "What should firefox do"
(Reporter)

Comment 2

10 years ago
Created attachment 313634 [details]
Dialog 2

Dialog: "select other application"
(Reporter)

Comment 3

10 years ago
Created attachment 313636 [details]
Dialog 3

Dialog: "filemanager: win 2000 / WINNT / System32 / dllcache / wordpad.exe"

Comment 4

10 years ago
Tried this on Windows XP with build:  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre

I can't reproduce this.  When I click the "Use this application next time" option, it uses that application next time.

Jari, please try this again in a recent nightly and see if the issue is fixed, if it isn't feel free to reopen the bug.

For now, I'm going to mark this as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Duplicate of this bug: 426217
(Reporter)

Comment 6

10 years ago
Tested: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008041206 Minefield/3.0pre

Status:
- The application is now preserved

What's still a bug:
- The checkbox "[x] Do this automatically...from now on" was selected
- When link was clicked again, it always poped up the dialog. It
  shouldn't have when the "Do this automatically" checkbox were selected.

The link to try: http://cante.net/~jaalto/tmp/bug/firefox/427063/sreenrc.txt
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

10 years ago
Created attachment 315348 [details]
rv:1.9pre Gecko/2008041206 Dialog box

The "[x] Do this automatically..." checkbox has no effect.
This dialog box is shwon again if same link is clicked again.
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 10

7 years ago
You got to be kidding. After Two years, with full of details, screen captures and all you expect people to hang around and have your bleeding edge software tested for you?

You have the test case in front of you in this bug report, so do the courtesy and show professionalism in developing the software.
You need to log in before you can comment on or make changes to this bug.