Last Comment Bug 427167 - [OS X] Crash [@ dataRead] uploading a file at wordpress.com / YouTube / Vimeo
: [OS X] Crash [@ dataRead] uploading a file at wordpress.com / YouTube / Vimeo
Status: RESOLVED WORKSFORME
[#96 Firefox 3.5.5 topcrash]
: crash
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 18:17 PDT by Simon Howes
Modified: 2013-07-09 05:20 PDT (History)
13 users (show)
mbeltzner: blocking1.9-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Apple Crash Report (44.37 KB, text/plain)
2008-04-16 11:52 PDT, Simon Howes
no flags Details

Description Simon Howes 2008-04-04 18:17:58 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040404 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040404 Minefield/3.0pre

Try to upload a file, whether audio, video or image results in browser quitting.

One of my crashes - http://crash-stats.mozilla.com/report/index/712ca2cc-029e-11dd-bceb-001cc4e2bf68


Of note, these have the same errors: http://crash-stats.mozilla.com/report/list?range_unit=weeks&query_search=signature&query_type=contains&signature=%400xffff08a0&query=%400xffff08a0&range_value=1

Reproducible: Always
Comment 1 Matthias Versen [:Matti] 2008-04-05 08:05:07 PDT
Just to be sure : Does this also happen in the Firefox safemode ?
The stack trace is code from the OS itself...

Comment 2 Håkan Waara 2008-04-05 08:09:47 PDT
Can you give an example of where to upload if I want to reproduce this crash? Preferably somewhere I don't have to register for a new account...
Comment 3 Håkan Waara 2008-04-05 08:54:33 PDT
There sure seems to be a lot of crashes related to this, as noted in comment 0.

We need a reliable and simple way for developers to test this. Does anyone have a good testcase, or reliable steps?

So, what I think is happening is that somewhere OS X is throwing an exception that we're not handling. My first suspicion was nsFilePicker.mm -- that somehow when a user has chosen a file, OS X throws, but it looks like we've guarded against exceptions there. 

A theory: maybe breakpad is not handling objc exceptions yet, which is why we see all these bad stacks. Ted?

Confirming, to make sure it shows up in people's queries.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2008-04-05 09:59:39 PDT
Yesterday's builds didn't have symbols uploaded, fallout from another bug. I backed that out, so today's builds should be fine. We are handling ObjC exceptions (in a way), they'll show up under one signature (but I can't recall what it is).
Comment 5 Steven Michaud [:smichaud] (Retired) 2008-04-05 13:20:29 PDT
Simon:  Do try to find a way to reliably reproduce your crash using a
publicly available URL (or testcase).

All:  Often it's better not to search on whatever's at the top of the
crash stack ... especially if that's a numerical address.  Otherwise
you'll (often) just get a bunch of unrelated crashes.

Here are searches on the second and third items in the stack that
Simon reported in comment #0.  In both cases I searched for "One of
the Top 10 Stack Frames" "is exactly" (in my experience using
"contains" here usually returns no results, possibly due to a bug in
the search engine).

http://crash-stats.mozilla.com/?do_query=1&branch=1.9&platform=mac&query_search=stack&query_type=exact&query=dataRead&date=&range_value=1&range_unit=weeks
http://crash-stats.mozilla.com/?do_query=1&branch=1.9&platform=mac&query_search=stack&query_type=exact&query=CFReadStreamRead&date=&range_value=1&range_unit=weeks
Comment 6 Matthias Versen [:Matti] 2008-04-05 13:31:37 PDT
i think must of us know that the end of a stack doesn't mean that the cause is there and the end of the stack may be different. 
Using the range query from comments 0 is already enough to get many reports with "uploading at wordpress" and that's enough to triage and see that it's a common problem
Comment 7 Simon Howes 2008-04-06 03:19:20 PDT
Just for clarity.  To upload files a popup Javascript appears.  You browse for the file, when it start to upload if you click anywhere in the browser it crashes.  If you do not click, the browser does not quit.
Comment 8 Simon Howes 2008-04-06 03:28:00 PDT
I have just tested wordpress ( http://wordpress.org/ ) on my local machine.  /wp-admin/post-new.php  is where the uploader can be found.  Next to "Add media" click on one of the image to load the upload frame.  Find a file, begin to upload and click away from the uploading window.  If someone with some knowledge could make a testcase.  
Comment 9 Matthias Versen [:Matti] 2008-04-12 14:10:24 PDT
*** Bug 428699 has been marked as a duplicate of this bug. ***
Comment 10 Mike Beltzner [:beltzner, not reading bugmail] 2008-04-14 14:46:27 PDT
I don't think we can block on this until there's better STR. This is WFM at this moment, but feel free to renom if we can lock this down a bit better.
Comment 11 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2008-04-15 10:37:34 PDT
Simon, which version of Wordpress are you using? I cannot find the "Add media" link. Was this included with Wordpress 2.5?
Comment 12 Simon Howes 2008-04-16 11:51:41 PDT
Version 2.5.
Comment 13 Simon Howes 2008-04-16 11:52:32 PDT
Created attachment 316065 [details]
Apple Crash Report

I hope this is more clear.
Comment 14 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2008-05-22 07:21:39 PDT
Simon, I just upgraded to 2.5.1 and I'm not able to reproduce this issue with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052104 Minefield/3.0pre ID:2008052104. Could you please retest if it is still crashing for you?
Comment 15 Jesse Ruderman 2009-08-18 15:27:49 PDT
dataRead crashes are frequent enough to make the mac-specific topcrash list, but not the cross-platform list.

mac topcrash #18 for firefox 3.0.13
mac topcrash #22 for firefox 3.5.2
Comment 16 Jesse Ruderman 2009-08-18 15:32:45 PDT
Simon's stack trace includes a function from com.marcmoini.smartscrollx_sxobjc (/Users/Simon/Library/Application Enhancers/Smart Scroll.ape/Contents/Resources/sxobjc.bundle/Contents/MacOS/sxobjc).  I wonder if it's responsible for the crash, at least for the one on his machine.  I know it has been blamed for Safari crashes.
Comment 17 Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-10-06 21:28:54 PDT
Given the rest of the stack (e.g., CFNetwork, which Gecko doesn't call/use for networking, but which Flash does) and the fact that the default WordPress uploader is a Flash applet, I'd put my money on this being a Flash-related crash.  (Also, neither of the Camino reports for dataRead have SmartScroll installed.)

In Camino's URL report, this crash shows up under 

http://www.me.com/uploader/en
http://www.youtube.com/my_videos_upload
Comment 18 Jonathan del Strother 2009-12-14 09:50:21 PST
Hi - we saw this quite a bit on audioboo.fm which uses swfupload - FF3.5.5 would quite regularly crash if you closed the popup window in the middle of an upload.

However, I can't seem to reproduce it on 3.5.6 or 3.6 - was it fixed?
Comment 19 Ted Mielczarek [:ted.mielczarek] 2009-12-14 09:56:05 PST
Jonathan: it's quite possible this was a crash in the Flash plugin which has since been fixed. (Have you updated your Flash?)
Comment 20 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2009-12-14 11:33:02 PST
I have contacted a couple of crash reporters too. Lets wait for their feedback.
Comment 21 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2009-12-15 04:58:28 PST
One crash reporter told me that she has no Flash installed on her system.
Comment 22 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2009-12-17 03:39:55 PST
Got other feedback. None of the crash reporters from whom I got a reply have Flash installed on their system. Seems like Flash is not related to this particular crash. One other reporter states that Firefox crashes when she is uploading .mov files to Youtube from the desktop.
Comment 23 Sheila Mooney 2011-11-28 21:45:02 PST
Still showing in 8.0.1 and 9.0 but very low volume - 2 in the past 4 weeks.
Comment 24 Wayne Mery (:wsmwk, NI for questions) 2013-07-09 05:20:55 PDT
Current crash rate is near zero** and nothing like what was originally reported (and still happening) for 3.x versions***. I doubt it's worth keeping this bug open, but please reopen if you feel otherwise.

** 5 crashes in the past 10 months for version 14 or newer.
bp-6937be40-7661-4c73-9e98-3fb932130118 14
bp-7485a125-4e01-4101-9481-03d0d2120924 15
bp-be0a688d-a072-4b09-addd-c37542121002 15.0.1
bp-2d2b348f-4240-4cea-b04e-8641e2121023 16.0.1
bp-926a9182-1d64-4b82-b3bf-dcca82120928 14.0.1


*** typical 3.x stack
bp-5bc65614-980d-45f6-966b-a25b32130101
0 		@0xffff08a0 	
1 	CoreFoundation 	dataRead 	
2 	CoreFoundation 	CFReadStreamRead 	
3 	CFNetwork 	transmitRequest1 	
4 	CFNetwork 	httpRequestStreamCallBack 	
5 	CFNetwork 	connectionRequestCallBack 	
6 	CoreFoundation 	_CFStreamSignalEventSynch 	
7 	CoreFoundation 	CFWriteStreamSignalEvent 	
8 	CFNetwork 	httpWrFilterStreamCallBack 	
9 	CoreFoundation 	_CFStreamSignalEventSynch 	
10 	CoreFoundation 	CFWriteStreamSignalEvent 	
11 	CFNetwork 	_SocketCallBack

Note You need to log in before you can comment on or make changes to this bug.