Search bar crowds out bookmarks when placed on the bookmarks toolbar

VERIFIED DUPLICATE of bug 447571

Status

()

VERIFIED DUPLICATE of bug 447571
11 years ago
10 years ago

People

(Reporter: trav, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

To maximize the displayed length of the current URL I'm visiting, I (very long ago) moved the built-in search box from the navigation toolbar down to the bookmarks toolbar. There are also a few bookmarks on the toolbar (see image "correct.png" which hopefully I can upload after I file this report). As of beta 5, when I launch Firefox the search box is too wide and hides those bookmarks (see image "incorrect.png").

If I right-click on the navigation toolbar and select "Customize...", and then click "Done" - even if I haven't done anything - the bookmarks toolbar will then display correctly. If I then go to View -> Toolbars and unselect "Bookmarks Toolbar", then repeat that and tell it to once again display the bookmarks toolbar, the toolbar search box will be obscuring the bookmarks that are there.

On a possibly related note - often when I'm in "customize toolbar" mode in beta 5, the various toolbar buttons will not be draggable and instead will continue to function as if I'm in normal mode.


Reproducible: Always

Steps to Reproduce:
1. Drag the search box from the navigation toolbar onto the bookmarks toolbar.
2. Restart Firefox 3.0 beta 5.
3. Observe the improper display of the bookmarks toolbar
Actual Results:  
The search box will obscure all bookmarks (but not buttons) on the bookmarks toolbar.

Expected Results:  
The search box should only fill the unused space.
(Reporter)

Comment 1

11 years ago
Created attachment 313834 [details]
Screenshot of the incorrect toolbar (incorrect.png)
(Reporter)

Comment 2

11 years ago
Created attachment 313835 [details]
Screenshot of how it's supposed to look (correct.png)
(Reporter)

Updated

11 years ago
Attachment #313834 - Attachment description: Screenshot of the incorrect toolbar → Screenshot of the incorrect toolbar (incorrect.png)

Comment 3

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040500 Minefield/3.0pre

Works fine for me, except for right after I hide and show the bookmarks toolbar.  The search bar makes itself a reasonable size in new windows.
Summary: As of beta five, toolbar customization/organization is funky → Search bar crowds out bookmarks when placed on the bookmarks toolbar
(Reporter)

Comment 4

11 years ago
In new windows I see the same thing as Jesse - even if, in my main window, the search bar is too big (e.g. exhibiting the reported problem), it'll be sized correctly in the bookmarks toolbar of any new window.
Travis, can you reproduce this issue in a fresh profile? If yes, please give detailed steps to reproduce.
Hardware: Macintosh → All
Version: unspecified → Trunk
Ok, got it. You only have to reduce the size of the main window so that the chevron appears. Afterwards resize it to normal size. As result the search bar isn't updated in its size.

This also happens on Windows Vista.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
(Reporter)

Comment 7

11 years ago
Well, unfortunately (from the point of view of this bug report) upgrading to RC1 seems to have solved the problem. I haven't yet been able to get it to happen since I upgraded.

I should have mentioned that starting with a new profile did not solve it - that was something I'd tried. With RC1 I went back to the original profile and have not seen the issue.
(Reporter)

Comment 8

11 years ago
I just tried the steps you described, and I do see the buggy behavior - the persistent » symbol stays there when I bring the window back up to a larger size. That isn't really quite the same issue as before though. With the beta 5 bug I didn't have to do anything to trigger the problem.

Comment 9

10 years ago
I am still noticing this bug in Vista. Note that I have also moved the main menu to the far left of the bookmarks toolbar.

Comment 10

10 years ago
I am experiencing this problem on Linux.  I'm not familiar with hg yet, but I think the build I am using is:

$ hg parents
changeset:   19032:bf398930da3d
tag:         tip
user:        Johnny Stenback <jst@mozilla.com>
date:        Tue Sep 09 19:56:09 2008 -0700
summary:     Followup fix for bug 453571 to fix typos pointed out by bz in the bug.

)

Comment 11

10 years ago
Also, bug 447571 may be a duplicate, and contains a patch.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.