If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New tab behavior does not prefs or documentation.

RESOLVED DUPLICATE of bug 405239

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 405239
10 years ago
9 years ago

People

(Reporter: Lint Hasenpfeffer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/526.1+ (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040504 Minefield/3.0pre

as detailed at http://support.mozilla.com/en-US/kb/Shortcuts, cmd-click "Open in Background Tab" instead opens the tab in the background and when switches to it without user interaction.

This is different then the shift-cmd-click behavior in which the tab is in front immediately.

Reproducible: Always

Steps to Reproduce:
1. cmd click on a link
2.
3.
Actual Results:  
new tab opens, the tab gets switched to. 

Expected Results:  
loaded in a background tab intel manually selected by the user
(Reporter)

Comment 1

10 years ago
The problem above seems to specifically occur on fark.com when ccmd-clicking the link to follow to the stories. the default behavior of said links is to open in a new window. When opening link in a new tab it becomes a tab but then switches although its supposed to be a BG tab. I believe that the choice of the user should override the pop-activation behavior of the site.
(Reporter)

Comment 2

9 years ago
If the cookie setting is 'ask me every time' is turned on. When a site on a tab that is loading in the background wants to set a cookie the tab will come forward, forcibly taking focus away from the tab you are browsing in. This is quite confusing. I can think of 2 possible better behaviors (which are not mutually exclusive):

1) wait until the tab is switched to ask about cookies
2) the cookie dialog can open in front of the tab that is current being browsed and list the the number and title of the tab that is asking to set the cookie.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405239
You need to log in before you can comment on or make changes to this bug.