Site does not recognize SeaMonkey as a Mozilla browser

VERIFIED DUPLICATE of bug 401709

Status

Tech Evangelism Graveyard
English US
--
minor
VERIFIED DUPLICATE of bug 401709
10 years ago
3 years ago

People

(Reporter: John Carpenter, Unassigned)

Tracking

({helpwanted})

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

Often (but not always - intermittent) when I bring up comcast.net for Webmail or online services, I get a page that says I need to upgrade my browser because it doesn't recognize SeaMonkey 1.1.9.  But Mozilla is one of the browsers it suggests downloading to replace it.  What would it take for SeaMonkey to answer version inquiries with the Mozilla version that it incorporates? 

Reproducible: Sometimes

Steps to Reproduce:
1. in Address line, type http://www.comcast.net/
2. Observe message screen that Comcast sends.
3.
Actual Results:  
Today, it displayed the regular Comcast screen.  But often it does not, and I have to click on an obscure link to bypass the error/update screen.  Not user-friendly on Comcast's part.  So, can we tell them what they want to hear? 

Expected Results:  
It should recognize the browser and go directly into the Comcast.net main page.


This happened before and after I installed the NoScript and Cookie Manager plug-ins.
(Reporter)

Updated

10 years ago
Keywords: helpwanted
Version: unspecified → SeaMonkey 1.1 Branch
No, we can't tell them want they want to hear, they are just using a broken browser sniffing javascript. They search for Firefox inside the UI and they are not looking for Gecko.

You should send them a mail with this link : http://geckoisgecko.org/
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Mozilla Application Suite → Tech Evangelism
QA Contact: general → english-us
Version: SeaMonkey 1.1 Branch → unspecified
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401709

Updated

10 years ago
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.