When loading a picture through direct link, picture is blacked out

RESOLVED DUPLICATE of bug 411831

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 411831
10 years ago
10 years ago

People

(Reporter: Jeff Bade, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5

Open a picture via direct link to the file (see demonstrative URL). The picture shows up as a black box if it is resized by Firefox. When you click to bring the picture back to normal resolution the picture displays fully. In some instances after correctly displaying when it is again resized to fit the screen the entire picture will show. I'm not sure if it only applies to .jpg files or all picture types. 

Reproducible: Always

Steps to Reproduce:
1. Open URL ending with file extension (i.e. .jpg) 
2. 
3.
Actual Results:  
Firefox displayed resized image as a partially blacked out box fit to the screen. When taken to full size the picture is displayed correctly. 

Expected Results:  
Expected to have image scaled to fit the screen and displayed in entirety. When brought to full scale also displayed correctly. 

Default Theme for Firefox 3 beta 5. Correctly functions in FF 2.0.13. Using KDE 3.5.9 Kubuntu Hardy Heron BETA.
(Reporter)

Comment 1

10 years ago
Created attachment 313989 [details]
What it looks like when scaled image is displayed incorrectly
I'm sure that this is a dupe of bug 411831
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411831
You need to log in before you can comment on or make changes to this bug.