Flight search results show broken layout formats

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(4 attachments)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040704 Minefield/3.0pre
Build Identifier: 

The layout of the results from Alaskaair.com seems broken and unrendered.   See screenshot.

Also, folow the STR below for exact results.  It doesnt break for every search case.


Reproducible: Always

Steps to Reproduce:
1. Install a recent nightly, and goto URL above
2. Select these search parameters.  
Depart:   SJC,  5/23/2008, select 6pm to midnight.
Return:  SEA, 5/26/2008, select noon-5pm
3. Search for flights
4. Verify the layout of the results are unformatted and unrendered
Actual Results:  
Results formatting is not formatted correctly

Expected Results:  
Results should be correctly formatted.
Reporter

Comment 1

11 years ago
addition note: saving the webpage locally and opening it up from the desktop renders the same results.
Reporter

Comment 2

11 years ago
This also Does not repro on Fx2.0.0.13
Flags: blocking1.9?
This is the source of the page that shows the wrong layout. I've stripped it from script and img tags, but I made sure it still shows the strange rendering on trunk.

I noticed that a lot of table rows have display: inline-block; set as style. When I remove those, the layout looks also correct on trunk.
So this seems like a tech evangelism issue to me, because now that Firefox does something with inline-block, the site looks bad, because it is misusing the inline-block rule.
Also, see Opera9, where you get to see the same problem.
Here I've attached the same (zipped up) page, but now with the  style="display: inline-block;" rule removed for all table rows.
This one just looks just fine in current trunk build (although there are some tiny rendering differences compared to branch).
Assignee: nobody → english-us
Blocks: inline-block
Component: GFX → English US
Flags: blocking1.9?
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Issue appears to be resolved.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.