Last Comment Bug 427713 - embedded color profiles in svg are ignored
: embedded color profiles in svg are ignored
Status: NEW
: dev-doc-needed, helpwanted
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal with 11 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://www.w3.org/Graphics/SVG/Test/2...
Depends on:
Blocks: 455077 svg11tests 418538 437300
  Show dependency treegraph
 
Reported: 2008-04-08 00:50 PDT by Hendrik Lönngren
Modified: 2014-10-13 22:50 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hendrik Lönngren 2008-04-08 00:50:50 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Firefox 3 beta 5 doesn’t pass the official test (given in the URL).

Now with color management, this should be fixable, right?

Reproducible: Always
Comment 1 Hendrik Lönngren 2008-04-08 01:21:33 PDT
I forgot to tell – I have gfx.color_management.enabled turned on, but still …
Comment 2 Glenn Randers-Pehrson 2008-06-20 10:56:33 PDT
The SVG portion of the test page still fails with FF-3.0, WinXP, color_management enabled.  Note that the difference is subtle: the lower right image is supposed to be somewhat brighter than the upper left one.
Comment 3 Sven Diedrichsen 2010-01-06 05:03:25 PST
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5 (.NET CLR 3.5.30729)

The SVG Test http://www.w3.org/Graphics/SVG/Test/20061213/htmlEmbedHarness/full-color-prof-01-f.html is also broken in the above named Firefox Version.

In the SVG image one rectangleis shown brown where it should be light red and 
the colors are a bit pale overall.
Comment 4 Gábor Stefanik 2010-12-13 09:48:47 PST
Sorry to evangelize, but still not fixed in 4.0 beta 7 - in fact, I don't see any developer input on this page.

Glenn, are you actually working on this bug?
Comment 5 Glenn Randers-Pehrson 2010-12-13 09:58:14 PST
No, Resetting assignee to default.

Note You need to log in before you can comment on or make changes to this bug.