Closed Bug 427837 Opened 15 years ago Closed 15 years ago

fx3 beta5 mac only crash [@ objc_msgSend]

Categories

(Core :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 426499

People

(Reporter: chofmann, Unassigned)

Details

currently the #6 ranked top crash is a Mac Only problem with signature

0  	libobjc.A.dylib  	objc_msgSend  	
1 	XUL 	imgRequestProxy::OnStopFrame 	mozilla/modules/libpr0n/src/imgRequestProxy.cpp:452
2 	XUL 	imgRequest::OnStopFrame 	mozilla/modules/libpr0n/src/imgRequest.cpp:527
3 	XUL 	nsICODecoder::Close 	mozilla/modules/libpr0n/decoders/bmp/nsICODecoder.cpp:120
4 	XUL 	imgRequest::OnStopRequest 	mozilla/modules/libpr0n/src/imgRequest.cpp:723
5 	XUL 	nsHttpChannel::OnStopRequest 	mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:4421
6 	XUL 	nsInputStreamPump::OnStateStop 	mozilla/netwerk/base/src/nsInputStreamPump.cpp:576
7 	XUL 	nsInputStreamPump::OnInputStreamReady 	mozilla/netwerk/base/src/nsInputStreamPump.cpp:401
8 	XUL 	nsInputStreamReadyEvent::Run 	mozilla/gfx/cairo/cairo/src/cairo-hull.c:107
9 	XUL 	nsThread::ProcessNextEvent 	mozilla/xpcom/threads/nsThread.cpp:510
10 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:180


Comments include a wide variety of tasks so maybe something behind the scenes like auto check for update might be at the root of the problem..

was trying to check for updates

Was quitting and removing personal data.

visiting docstor.com

Trying to print out boarding pass from SW airlines; crash

Just closing the application when finished.

I was trying to hide FF to do other things when it just disappeared.

I was reopening the last closed tab.

I was perusing a website and wanted to print a receipt. I clicked on the 'print this page' link which was to a javascript method and it froze and then died after a about 30 seconds and giving me the apple PCoD for about 10 seconds.

I just clicked on the icon in the dock and it crashed...

I closed the freakin program down.... what gives?

I closed it.

I clicked on the Help menu, and it crashed.

FF3b5 is crashing *much, much* more than b4. I was trying to move Gmail's tab, and it crashed.

Downloading a file and scrolling my myspace inbox when it crashed

crashed while browsing site... borders around pictures in this site (or any iWeb site) cannot be seen nor are picture galleries made in iWeb visible.	

Attempted to use QuickSilver to access menu items.

accessing help menu 


this also might sound a bit like bug 400291  but there is so much going on there it might be better to start anew...
putting on the radar until we know more..
Flags: blocking1.9?
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426499
There are _lots_ of unrelated crashes that have objc_msgSend as their top frame.  One of them is bug 426499 (which is probably itself a topcrasher).

It's often better to group crashes by the 2nd or 3rd frame.  This case is a prime example.
For those who don't know it, objc_msgSend() is used to call _any_ method on _any_ Objective-C object.
You need to log in before you can comment on or make changes to this bug.