KB article: Mozilla Crash Reporter

VERIFIED FIXED

Status

support.mozilla.org
Knowledge Base Articles
--
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Jason Barnabe (np), Assigned: myles7897)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Like http://support.mozilla.com/en-US/kb/Quality+Feedback+Agent but for Breakpad.
(Assignee)

Comment 1

10 years ago
http://support.mozilla.com/en-US/kb/Mozilla+Crash+Reporter

Updated

10 years ago
Assignee: nobody → myles7897

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

10 years ago
I don't think the link to w.m.o or the signature search is useful.

See if you can use SHOWFOR to explain the situation to Firefox 2 users.

The screenshots are pretty blurry.

Is there a situation where you couldn't use about:crashes? If not, I'd say drop the section on getting it manually. I suppose if Firefox crashes at startup...

Put the section on what happens after a crash before the section on how to look up incidents.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

10 years ago
why would we take those out? (the links).

I think they are used when people want to get to know more about the crash site, w.m.o, and we people want to try and troubleshoot there own problems, the search.  Troubleshooting your own problems is the whole goal of KB articles.
(Reporter)

Comment 4

10 years ago
As far as I can tell, w.m.o provides info on the design of Breakpad, not anything that would help you troubleshoot your problems. The signature search is useful to find reports given a signature, but the user already has a report, so what will other people's reports give them?
(Assignee)

Comment 5

10 years ago
ok, I will take out those links.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 6

10 years ago
is this one complete?
(Reporter)

Comment 7

10 years ago
I've updated it per my comments in comment 2. I've also done a lot of formatting and grammar changes, and I fixed up the description of the UI because it didn't match what was there. The changes are significant enough that I'd like another reviewer to take a look.
(Assignee)

Comment 8

10 years ago
I think it looks good, except some things.

1. When restarting Firefox, it gives you the optional to Restore Tabs, most crashes are caused by the tabs you were on, so this is dangerous.  WE should warn against doing this.

2. When it says quit Firefox, you say "Close Firefox."  Now I am not sure on the technical aspect of this, but some people might perceive this as saying that Firefox is still running, which they might think this would be bad, so you might want to rephrase that.

1, is a must, while 2 is a hypothetical situation so it is not as important as 1.  I understand that this is assigned to me, so if you want me to just do it please say so.

Format looks great.
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED

Comment 9

10 years ago
Moved to KB at:
Sat 17 of May, 2008 16:01 EST

Any further discussion should go on the staging copy:
<http://support.mozilla.com/kb/*Mozilla+Crash+Reporter>
Status: RESOLVED → VERIFIED

Updated

10 years ago
Blocks: 421151
You need to log in before you can comment on or make changes to this bug.