Scrolling with Mighty Mouse button continues on too long

VERIFIED DUPLICATE of bug 418351

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 418351
10 years ago
10 years ago

People

(Reporter: Mikael Brannstrom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040804 Minefield/3.0pre

This is the same as bug 321853 (Camino) but this one is for Firefox.

When using the scrolling button on Apple Mighty Mouse on long web pages, the
scrolling continues on after I've stopped spinning the button. Safari does not have these problems.

Reproducible: Always
Does the problem also occur on long pages that are not as slow-rendering as the one you linked in the url field? Could you test it with http://planet.mozilla.org/, for example?
How long does the scrolling continue after you stop spinning the button?
Is smooth scrolling enabled? (Preferences » Advanced » General)
(Reporter)

Comment 2

10 years ago
Planet Mozilla works better, but not perfect. Smooth scrolling is disabled.

When smooth scrolling is enabled the problem also appears on Planet Mozilla.

The scrolling continue for about 0.1 seconds on Planet Mozilla and about 0.5-0.7 seconds on Aftonbladet (http://www.aftonbladet.se).
Sounds like the same problem as bug 418351:
We're repainting after every scroll step, which leads to problems when the scroll steps come in faster than we can keep up rendering. We should only be rendering after all pending scroll steps have been processed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418351

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.