Closed Bug 427971 Opened 14 years ago Closed 14 years ago

Content of long div not all displayed when "overflow: scroll" or auto

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: groups, Unassigned)

Details

Attachments

(1 file)

341 bytes, text/html
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040805 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040805 Minefield/3.0pre

When viewing a simple page (such as that generated by the attached php), the div's contents are truncated.

The first 1637 lines (on my system) render fine, then there is enough blank space to contain the rest of the text, but no text in there. The div's scroll bars run all the way to the bottom of the page (grayed out), but there is no content displayed. FF continues to run ok, and doesn't show any signs of stress about the large page, it just only shows the first 1600 or so lines of content. The final displayed line has only the top part displayed down to some apparent pixel limit from the top of the page / div.

This only happens when the div has an overflow of "scroll" or "auto". "visible" and "hidden" result in the entire contents being displayed correctly.

Loading the same page in IE, safari, and opera all show the full page with all content.

Hello
:-Lightinthedark

Reproducible: Always

Steps to Reproduce:
1. Copy the code above onto a handy php server, or create a page with over 1700 lines of content
2. View the page in Firefox
3. Scroll down and see the text stop being rendered.
Actual Results:  
All text rendered fine down to 1637. line 1638 has only the top few pixels of the text shown

Expected Results:  
All text rendered all the way down to line 10000.
Attached file Test Case
This is a simple php file to generate 10000 lines of text inside a div
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
Hi,
I did see bug 215055 when checking I was not submitting a duplicate, but didn't check, the test cases. The test case at "a testcase from a bug dupped to this one" ( https://bugzilla.mozilla.org/attachment.cgi?id=249560 ) there does seem to demonstrate the same thing as I'm experiencing. Sorry for the duplication, and good luck fixing it chaps :-)
You need to log in before you can comment on or make changes to this bug.