Closed Bug 428024 Opened 12 years ago Closed 12 years ago

Adding second monitor with xrandr changes zoom (content+toolbars)

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 394103

People

(Reporter: mozilla-bugs, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

When i have my X running with only one monitor and change that layout with:

xrandr --output VGA --left-of LVDS --mode 1024x768

Everything in firefox gets resized

Reproducible: Always

Steps to Reproduce:
1. Start up with one monitor on
2. xrandr --output VGA --left-of LVDS --mode 1024x768
3. Open a new firefox window
Actual Results:  
Everything in firefox gets zoomed in

Expected Results:  
Don't know, maybe thats not a bug, its a feature ;). Makes sense for big resolutions but i guess in a normal multi-monitor layout thats not what people expect.

Keep everything as is if the virtual resolution changes
Looks like that happens only when firefox is running while changing the resolution.
Okay, here are the more precise steps to reproduce:
1. Start X with one monitor
2. Start firefox
3. xrandr --output VGA --left-of LVDS --mode 1024x768
3. Open a new firefox window (a new tab works fine)
...the only thing special if the 'Virtual 2048 1200' part which is needed for multiple monitors with xrandr
Attached image The bug
This should be fixed on trunk now.

You can test it with a nightly (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/) or wait for the first release candidate.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 394103
You need to log in before you can comment on or make changes to this bug.