If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

use of JavaScript date.getYear() returns 108 (instead of 2008)

VERIFIED DUPLICATE of bug 22964

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 22964
10 years ago
9 years ago

People

(Reporter: paul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

with:
 var d = new Date();

 d.getYear() returns 108 (instead of 2008)

Reproducible: Always

Steps to Reproduce:
1.declare the var : var d = newDate()
2.call d.getYear()
3. or paste the following lines:
  <SCRIPT  LANGUAGE="JavaScript">
<!-- 
var d = new Date();
document.write(d.getYear());
//--></SCRIPT>
Actual Results:  
d.getYear gives 108


Expected Results:  
the year is 2008  :)
(Reporter)

Updated

10 years ago
Keywords: dataloss

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: dataloss
Resolution: --- → DUPLICATE
Duplicate of bug: 22964
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.