Closed Bug 428097 Opened 14 years ago Closed 14 years ago

Bookmarks Toolbar menu item in Bookmarks Menu doesn't have a menu icon

Categories

(Firefox :: Theme, defect, P2)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
Firefox 3

People

(Reporter: adelfino, Assigned: mak)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre

Bookmarks Toolbar menu item in Bookmarks Menu doesn't have a menu icon.

Reproducible: Always

Steps to Reproduce:
1. Open the Bookmarks menu.
2. See the Bookmarks Toolbar menu item.
Actual Results:  
Bookmarks Toolbar has no icon.

Expected Results:  
Bookmarks Toolbar should have an icon.
Version: unspecified → Trunk
Attached image Screenshot.
Nominating as blocking since all this work around Library should be as consistent as possible, since it's new stuff that the user will experiment with.
Flags: blocking-firefox3?
I see this on Win Vista as well, confirming using  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocking because this is a regression - we used to show an icon here, what's going on?

Marco, could this be related to your checkin from bug 421483?
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3+
Keywords: regression
doubt it, i simply created some bookmark and moved a separator...
Assignee: nobody → mak77
Attached patch patch (obsolete) — Splinter Review
needs region
Attachment #314871 - Flags: review?(dietrich)
Status: NEW → ASSIGNED
This is WFM on Mac. Isn't auto the default value for -moz-image-region? Seems like you shouldn't need to specify it at all...
on win the style def is at the end of the file so probably region is defined in a previous styling (probably the generic container). will check later probably could be solved moving up the style in the css
Attached patch patchSplinter Review
so, after a check, the fix is only needed on winstripe since is the only theme that uses moz-region for bookmark-item, and being toolbar folder a bookmark-item[container] its region needs to be overloaded with auto.
Attachment #314871 - Attachment is obsolete: true
Attachment #314979 - Flags: review?(dietrich)
Attachment #314871 - Flags: review?(dietrich)
Priority: -- → P2
Target Milestone: --- → Firefox 3
Comment on attachment 314979 [details] [diff] [review]
patch

r=me, thanks!
Attachment #314979 - Flags: review?(dietrich) → review+
Attachment #314979 - Flags: approval1.9?
Comment on attachment 314979 [details] [diff] [review]
patch

a1.9=beltzner
Attachment #314979 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in browser/themes/winstripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/browser.css,v  <--  browser.css
new revision: 1.197; previous revision: 1.196
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.