Closed Bug 428098 Opened 14 years ago Closed 14 years ago

Most Visited item in Bookmarks Toolbar does not use a smart search icon

Categories

(Firefox :: Theme, defect)

defect
Not set
trivial

Tracking

()

VERIFIED FIXED
Firefox 3

People

(Reporter: adelfino, Assigned: wesj)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre

Most Visited item in Bookmarks Toolbar does not use a smart search icon.

Reproducible: Always

Steps to Reproduce:
1. See the Most Visited item in Bookmarks Toolbar.
Actual Results:  
The item uses a normal folder as an icon.

Expected Results:  
The item should use a smart search folder as an icon.
Version: unspecified → Trunk
Nominating as blocking since all this work around Library should be as consistent as possible, since it's new stuff that the user will experiment with.
Flags: blocking-firefox3?
OS: Windows XP → All
Hardware: PC → All
Attachment #314695 - Attachment description: Screenshot. → Screenshot in Windows XP.
Attachment #314701 - Attachment description: Screenshot in Ubuntu. → Screenshot in Ubuntu 7.10.
Looks like the query attribute isn't being checked/added here. Quick patch to just add this attribute check.
Attachment #314771 - Flags: review?
Attachment #314771 - Flags: review? → review?(dietrich)
Comment on attachment 314771 [details] [diff] [review]
Adds query attribute to toolbar buttons

r=mconnor, thanks!
Attachment #314771 - Flags: review?(dietrich) → review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3-
Comment on attachment 314771 [details] [diff] [review]
Adds query attribute to toolbar buttons

a=beltzner, thanks!
Attachment #314771 - Flags: approval1.9+
Assignee: nobody → wesley-johnston
mozilla/browser/components/places/content/toolbar.xml 	1.151 
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.