Closed Bug 428220 Opened 12 years ago Closed 12 years ago

Report broken website is broken!

Categories

(Firefox :: General, defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 425814

People

(Reporter: notforyourmail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_2; en-us) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

Report broken website asks me to agree to the privacy policy shown, which is blank.  Upon checking that I agree to the nonexistent policy and clicking Done, nothing happens.  However, going to the Help menu to try to report it will often cause Firefox to crash.  

Reproducible: Always

Steps to Reproduce:
1.  Try to select Report Broken Website
2.  Get unusable window
3.  Hang my head in shame at my failure to report a bug
Actual Results:  
Can't report the bug.  Sometimes, the browser will crash completely.  It seems to hang when I go to the help menu, but will usually produce the non-functional window before dying in ways too horrible to describe in a bug reporting webpage.  However, Crash ID 3def31ca-06a6-11dd-b1c1-001321b13766 might have more to say on the subject, such as:

Signature	objc_msgSend
UUID	3def31ca-06a6-11dd-b1c1-001321b13766
Time	2008-04-09 19:31:18-07:00
Uptime	322
Product	Firefox
Version	3.0b5
Build ID	2008032619
OS	Mac OS X
OS Version	10.5.2 9C7010
CPU	ppc
CPU Info	
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x956ea018
Comments	Tried to use the help menu after Yahoo mail failed to work properly.


Expected Results:  
Successfully report bug. Mozilla dev team finds and vanquishes the bug.  Firefox is the best browser ever!
the help menu is bug 400291, it's specific to 10.5.2, ppc.
The "Report a broken website" feature is broken for me too (10.4.x, with Greasemonkey as the nsIContentPolicy user).
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425814
You need to log in before you can comment on or make changes to this bug.