Closed Bug 428236 Opened 15 years ago Closed 15 years ago

Selecting snooze times from alarm popup always causes the first entry to be highlighted

Categories

(Calendar :: Alarms, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mattdoran76, Assigned: giermann)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.13pre) Gecko/20080331 Sunbird/0.8

When the alarm pops up and I want to snooze the alarm I press the "Snooze for" button which makes the list of snooze times appears. (e.g. 5 mins, 10 mins, 15 mins, etc).

As I hover over the selection with the mouse, the item highlights.... but as soon as I click the selection changes back to 5 minutes.

It makes setting a snooze in 0.8 almost unusable!

Reproducible: Always

Steps to Reproduce:
1. Set an alarm
2. Wait for alarm to appear.
3. Press the "Snooze for" button by clicking left mouse button.
4. Try to select the 15 minutes option.
Actual Results:  
The focus moves back to the "5 minute" option.

Expected Results:  
The 15 minute option should be selected.

When I click on the "15 minute" option and hold the left mouse button down the highlighting changes to the "5 minute" option.  I can then move the mouse around to re-select the option I want.... and then release the mouse.

Yuck.

If it makes any difference I'm running XP SP2 (x64).
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15pre) Gecko/20080409 Calendar/0.9pre.

However, it's just a display issue. 

The real value that was clicked on is used to snooze the alarm. This can be confirmed by setting the preference "calendar.debug.log" to true and observing the debug messages from calAlarmService in the Error Console.
I also argued about that.

Investigating I found, that removing line 61 from 'calendar-alarm-snooze-popup.xul' [1] would fix this problem:
>   onfocus="event.target.selectedIndex = 0;"

CC'ing Philipp to comment on the need or the source for this line...
If not needed, simply deleting this line works fine for me!

[1] http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-alarm-snooze-popup.xul#61
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Severity: major → normal
Summary: Serious problem selecting snooze times from alarm popup → Selecting snooze times from alarm popup always causes the first entry to be highlighted
I think this line was added to mimic the behavior of a standard popup. Opening the popup should make the first line selected. What needs to work with the line removed is opening the dropdown with the keyboard and pressing arrow down. The first item should be selected.

Not sure thats exactly the reason, but it was something along the lines. I did notice some other problems (i.e the radiobuttons are being shown and the border is gone), but thats probably another bug or local tree brokenness. 
I did not notice any other change by this patch...

(In reply to comment #3)
> I think this line was added to mimic the behavior of a standard popup. Opening
> the popup should make the first line selected. What needs to work with the line
> removed is opening the dropdown with the keyboard and pressing arrow down. The
> first item should be selected.
I did not see the first line being selected WITH this line, but keyboard arrow down is selecting the first item even without the line.

> Not sure thats exactly the reason, but it was something along the lines. I did
> notice some other problems (i.e the radiobuttons are being shown and the border
> is gone), but thats probably another bug or local tree brokenness. 
Did you notice these error after removing the line mentioned?
Please be more specific in your review if it is caused by the removal.
Assignee: nobody → giermann
Status: NEW → ASSIGNED
Attachment #316780 - Flags: review?(philipp)
Comment on attachment 316780 [details] [diff] [review]
Removal of the evil line

I guess we can do that. r=philipp
Attachment #316780 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in lightning build 2008070218 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.