tags pane opens with empty tag names if opens from tag->customize menu

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: mozdiav, Assigned: neil)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9pre) Gecko/2008040902 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9pre) Gecko/2008040902 SeaMonkey/2.0a1pre

Tags pane opens with empty tag names if opens from mail message context menu tag->customize menu.

Reproducible: Always

Steps to Reproduce:
1. select mail in mail list
2. right click on mail in list, choose tag->customize

Actual Results:  
Opens preferences window with tag pane; all tag names empty

Expected Results:  
tag pane should contain my tags
(Reporter)

Comment 1

11 years ago
Created attachment 314793 [details]
screenshot with empty tag names

Comment 2

11 years ago
Can you post the preference entries for mailnews.tags.* from your prefs.js, please?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

11 years ago
Assignee: mail → mnyromyr
Status: ASSIGNED → NEW

Comment 3

11 years ago
Oh, and do you get any related errors in Tools->Web Dev->Error Console?

Comment 4

11 years ago
While trying to reproduce this, I have noticed, that at first run the Tag-Names are listed like expected, but when I choose "Tag -> Customize" another time, the Name-Fields are empty like Igor has described.

There are no (related) Errors in Error-Console.

I have not changed the default Entrys, so there are this in my prefs.js:

user_pref("mailnews.tags.$label1.color", "#FF0000");
user_pref("mailnews.tags.$label1.tag", "Important");
user_pref("mailnews.tags.$label2.color", "#FF9900");
user_pref("mailnews.tags.$label2.tag", "Work");
user_pref("mailnews.tags.$label3.color", "#009900");
user_pref("mailnews.tags.$label3.tag", "Personal");
user_pref("mailnews.tags.$label4.color", "#3333FF");
user_pref("mailnews.tags.$label4.tag", "To Do");
user_pref("mailnews.tags.$label5.color", "#993399");
user_pref("mailnews.tags.$label5.tag", "Later");
user_pref("mailnews.tags.version", 2);
(Reporter)

Comment 5

11 years ago
no errors in error console

Comment 7

11 years ago
Created attachment 314981 [details] [diff] [review]
v1: delay updating textbox value

It seems that slower systems try to update the textbox values before the actual main window is ready; this happens when I run a Mac debug build with Venkman debugging and opening tags preferences from the standalone message window. ;-)

This patch delays the updates until after the frontend is (kinda) ready.
Attachment #314981 - Flags: superreview?(neil)
Attachment #314981 - Flags: review?(neil)
With Seamonkey trunk 2008/4/10 build, phenomenon could be observed.
 (a) With 5 standard tags + 3 added tags
     4 standard tags with tag name + 4 tags with blank tag name
 (b) With 5 standard tags + 10 added tags
     all tags were displayed with blank tag name

At "New Preference" via "Edit/Preference/READ THIS!", expand of "Mail&News" is possible when 4/10 build(was impossible when 4/08 build), and all above 15 tags were displayed with tag name at "Tags" panel.
Changes explained in "READ THIS!" on Mail&News/Tag looks to be landed on 2008/4/09 build.
(Assignee)

Comment 9

11 years ago
Created attachment 315080 [details] [diff] [review]
Alternative idea

It seems to me that the XBL for the textbox is missing sometimes (oddly I get it on the last tag, and only the first time I open Preferences.) Perhaps this change is a less hacky way of populating tags more reliably.
Attachment #315080 - Flags: review?(mnyromyr)
Comment on attachment 315080 [details] [diff] [review]
Alternative idea

That's cleaner, yes. 
(Despite the violation of the "do task in one place only" principle, but I don't think it's worth rewriting all callers.)
Attachment #315080 - Flags: review?(mnyromyr) → review+
(Assignee)

Updated

11 years ago
Assignee: mnyromyr → neil
(Assignee)

Comment 11

11 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Comment on attachment 314981 [details] [diff] [review]
v1: delay updating textbox value

Looks like this patch was superseded by Neil's suggestion, therefore obsoleting as this bug is resolved fixed as well.
Attachment #314981 - Attachment is obsolete: true
Attachment #314981 - Flags: superreview?(neil)
Attachment #314981 - Flags: review?(neil)
You need to log in before you can comment on or make changes to this bug.