Closed Bug 428398 Opened 13 years ago Closed 13 years ago

Request debug (leak) tinderboxes to be run on trunk Thunderbird

Categories

(Mozilla Messaging :: Release Engineering, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: gozer)

References

Details

Attachments

(2 files)

In bug 427980 I have submitted patches for getting the MailNews leak tests working again on tinderbox. Pending reviews, I believe the first version is ready to go.

We would therefore like to request debug tinderboxes suitable for running leak tests for all three platforms for trunk Thunderbird. Hopefully we'll have the patches in by the time we get them, if not I assume the configs will be in cvs and hence we can switch the leak test part on as soon as the patches are working.

I spoke to Rick about this on irc and we weren't quite sure which way we needed to get this done, but we both agreed filing a bug was the best way to start.
I too am not sure what's needed.  Is there a checkist documenting what steps need to happen?  That would make it easier to figure out who needs to be involved.

In particular, MoMo has hardware that's currently sitting idle, which is likely to be the right final hosting hardware for these VMs, but there's setup work needed there.  

Pushing to "Future" until the blocker and above questions are resolved. Any idea when the MoMo hardware would be ready to use?
Component: Release Engineering → Release Engineering: Future
Priority: -- → P3
Assigning to Gozer - the new IT guy for MoMo - at David's request.

Gozer, please see comment 0 for what we want.
Assignee: nobody → gozer
Blocks: 427627
Component: Release Engineering: Future → Release Engineering
Product: mozilla.org → Mozilla Messaging
QA Contact: release → release
The mailnews files are now in place, over to gozer.

gozer - if you didn't realise, it can take 5-10 seconds for the main window to close after the other windows have closed.
Delayed status update. We've got leak tests running on all 3 platforms, mostly keeping green. There is still one pending patch from Standard8 that needs landing, but apart from that, looking ready to move to the main Thunderbird tinderbox tree.
I've created this script to abstract away all the logic of running these tests. This way, the buildbot can blindly just run:

$> perl mailnews/test/performance/bloat/runtest.pl objdir-tb

And be left with the various *.log files it expects to analyse.
Attachment #345138 - Flags: review?(bugzilla)
Attachment #345138 - Flags: review?(bugzilla) → review+
Comment on attachment 345138 [details] [diff] [review]
[checked in] runtest.pl

nice.
We've had this running on Mac for about a day now and it seems to avoid the problem caused by bug 321783. We're hopefully going to be switching the bloat boxes live today, so I'd like to get this into the tree.
Attachment #345253 - Flags: review?(bienvenu)
Comment on attachment 345253 [details] [diff] [review]
[checked in] Stabilise Mac Bloat Test

it's a little odd that a method called shutdownMainWindow is checking if the compose window is up ;-)
Attachment #345253 - Flags: review?(bienvenu) → review+
(In reply to comment #9)
> (From update of attachment 345253 [details] [diff] [review])
> it's a little odd that a method called shutdownMainWindow is checking if the
> compose window is up ;-)

Oh well, that's consistent naming for you. Hopefully these problems will go away soon anyway.
Comment on attachment 345138 [details] [diff] [review]
[checked in] runtest.pl

Checked in:

http://hg.mozilla.org/comm-central/rev/d00fb8da1b02
Attachment #345138 - Attachment description: runtest.pl → [checked in] runtest.pl
Comment on attachment 345253 [details] [diff] [review]
[checked in] Stabilise Mac Bloat Test

Checked in:

http://hg.mozilla.org/comm-central/rev/a55e8ebd7ec6
Attachment #345253 - Attachment description: Stabilise Mac Bloat Test → [checked in] Stabilise Mac Bloat Test
The leak/bloat builders have been moved to the main Thunderbird tinderbox tree:

- Win2k3 comm-central bloat build  	
- MacOSX 10.4 comm-central bloat build
- Linux comm-central bloat build

And the tree is still green!
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.