Closed Bug 428419 Opened 14 years ago Closed 14 years ago

Browser hangs, then crashes when trying to view information on cached flv videos

Categories

(Core :: Networking: Cache, defect)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 421828

People

(Reporter: deyanmegara, Unassigned)

Details

(Keywords: crash, stackwanted)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

When I download a Flash video and then try to view information on it (and perhaps download it) in about:cache?device=disk, I find it in the list of cached files and click on the link. Then, the browser hangs for a while. After some time, it either shows a hex dump of the video file, or crashes (or even both). This also occurs in Windows XP.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.vbox7.com/ and open a video.
2. Open about:cache?device=disk and find the .flv file
3. Click on the file address link.
Actual Results:  
Browser hangs.

Expected Results:  
Browser should show information about the related file.
Component: General → Plug-ins
Keywords: crash, stackwanted
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Component: Plug-ins → Networking: Cache
OS: Linux → All
Resolution: --- → DUPLICATE
Duplicate of bug: 421828
You need to log in before you can comment on or make changes to this bug.