Last Comment Bug 428591 - idl is hiding the fact QUERY_TYPE_BOOKMARKS does not support grouping atm
: idl is hiding the fact QUERY_TYPE_BOOKMARKS does not support grouping atm
Status: RESOLVED FIXED
: dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 3.7a1
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 509868 384226
  Show dependency treegraph
 
Reported: 2008-04-11 15:19 PDT by cmtalbert
Modified: 2009-11-26 06:08 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta1-fixed


Attachments
Test case demonstrating the problem (6.36 KB, text/plain)
2008-04-11 15:19 PDT, cmtalbert
no flags Details
add idl notes (3.13 KB, patch)
2009-08-21 06:34 PDT, Marco Bonardo [::mak]
dietrich: review+
Details | Diff | Review

Description cmtalbert 2008-04-11 15:19:07 PDT
Created attachment 315193 [details]
Test case demonstrating the problem

The only RESULTS_AS setting that works for Bookmark queries is RESULTS_AS_URI.  For everything else, no results are returned in the result set.  

I'll attach a test that demonstrates this behavior. 

= Expected Behavior =
The results as queries should work for bookmarks too, the RESULTS_AS_DATE* should work if the bookmarks have a visit associated with them, the RESULTS_AS_SITE should always work since bookmarks have URIs associated with them.

= Actual = 
Only RESULTS_AS_URI returns any results for a bookmark query.
Comment 1 Marco Bonardo [::mak] 2009-08-21 06:34:34 PDT
Created attachment 395828 [details] [diff] [review]
add idl notes

this is true, our code actually does not allow grouping bookmarks, the idl does not say anything about that, so i'm going to add notes to the idl, and this should be fixed in future if possible adding support for more complex queries (rewriting the query builder class could make this easier).
Comment 2 Dietrich Ayala (:dietrich) 2009-08-21 10:35:42 PDT
(In reply to comment #1)
> this is true, our code actually does not allow grouping bookmarks, the idl does
> not say anything about that, so i'm going to add notes to the idl, and this
> should be fixed in future if possible adding support for more complex queries
> (rewriting the query builder class could make this easier).

please file a bug for this change, and make it block the query-builder-rewrite bug.
Comment 3 Dietrich Ayala (:dietrich) 2009-08-21 10:36:16 PDT
Comment on attachment 395828 [details] [diff] [review]
add idl notes

clear enough, r=me
Comment 4 Marco Bonardo [::mak] 2009-08-21 12:58:12 PDT
morphing the bug, this will handle idl comment only, i'll file a separate one for grouping
Comment 5 Marco Bonardo [::mak] 2009-08-21 13:43:03 PDT
http://hg.mozilla.org/mozilla-central/rev/b068cbe50c07
Comment 6 Marco Bonardo [::mak] 2009-09-14 10:20:42 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/668a8979b530
Comment 7 Eric Shepherd [:sheppy] 2009-11-02 07:05:00 PST
Updated the docs here:

https://developer.mozilla.org/en/nsINavHistoryQueryOptions#Result_type_constants
Comment 8 Gervase Markham [:gerv] 2009-11-26 06:08:35 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv

Note You need to log in before you can comment on or make changes to this bug.