Firefox 3.0b5 cannot open link from other application (e. g. IncrediMail)

RESOLVED DUPLICATE of bug 395891

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED DUPLICATE of bug 395891
10 years ago
10 years ago

People

(Reporter: UserFromBrazil, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When you try to open a link from other program (e. g. IncrediMail or SUMo), firefox.exe starts, but does not show up.

Reproducible: Always

Steps to Reproduce:
1. Open any program that has links in About...
2. Click the link(s)
3. Press Ctrl + Alt + Del and see that firefox.exe is running, but do not appear.
Actual Results:  
firefox.exe process was opened, but not Firefox's window.

Expected Results:  
Like in Firefox 2, open the age correctly.

My Firefox has the "-p" parameter.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Comment 1

10 years ago
What does it say in your registry under HKEY_CLASSES_ROOT\http\shell\open\command ?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> What does it say in your registry under
> HKEY_CLASSES_ROOT\http\shell\open\command ?
> 

"C:\Program Files\Mozilla Firefox 3 Beta 5\firefox.exe" -requestPending -osint -url "%1"

???
(Reporter)

Updated

10 years ago
Severity: normal → critical
I had some related problems in past, but now it works for me. Can someone confirm it?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051011 Minefield/3.0pre

Comment 4

10 years ago
Confirmed for me, same with Klipfolio and start / run.

I have multiple Profiles if that affects anything.

Comment 5

10 years ago
It is the -requestPending parameter, remove that and it works fine.
I think this is a duplicate of Bug 395891. If so, can anyone dupe it?

Comment 7

10 years ago
Yes, this sounds exactly the same as bug 395891 (since the reporter mentions using the -p parameter to select a profile).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395891
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.