Closed Bug 428810 Opened 12 years ago Closed 11 years ago

List bullet alignment (ol, ul) with floats inside the list item is broken in some cases

Categories

(Core :: Layout: Block and Inline, defect, P4)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: mats, Assigned: dbaron)

References

Details

(Keywords: regression, testcase)

Followup from bug 427370.

Testcases coming up...
One testcase that still fails is attachment 314558 [details] (Testcase #9 in bug 427370).
We also need a testcase for the nested block situation David described in
bug 427370 comment 35 (make sure Patch rev. 4 in that bug fails that test).
Keywords: regression, testcase
This should be easy to fix with the new float manager, which we can easily extend to do available space calculation based on an old saved state.  But I don't want to do that until bug 25888 lands, since otherwise I'll get massive merge conflicts.
Depends on: 25888
Flags: blocking1.9.2?
Actually, I think I need to fix this in the middle of the stack of patches for bug 25888 (since it will depend on some of the patches in that bug, but some of the patches there will depend on this).
Assignee: nobody → dbaron
Status: NEW → ASSIGNED
... need to also test the cases where the line with the bullet gets pushed down below floats, including those where there are also floats within it
Fixed by http://hg.mozilla.org/mozilla-central/rev/df0130484852
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Priority: -- → P4
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.