ChatZilla appends underscores infinitely, when nickname is unavailable on server

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Mitch, Assigned: Mitch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.82])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041206 Minefield/3.0pre
Build Identifier: ChatZilla 0.9.81

If a nickname is already in use on a server, ChatZilla appends an underscore to the previously-tried nickname, in an attempt to choose a unique, unused nickname. There is no automatic stop condition for this process.

Reproducible: Always
(Assignee)

Comment 1

10 years ago
Created attachment 315389 [details] [diff] [review]
Patch v1.0

This patch limits retrying to the number of nicknames on the nickname list plus 3.
Assignee: rginda → mitch_1_2
Status: NEW → ASSIGNED
Attachment #315389 - Flags: review?(silver)

Comment 2

10 years ago
Comment on attachment 315389 [details] [diff] [review]
Patch v1.0

You broke the nick list version by moving the changeNick bits into the else if. Now, if |tryList| is true, it'll never actually change nickname, as far as I can tell. r- on that.
Attachment #315389 - Flags: review?(silver) → review-
(Assignee)

Comment 3

10 years ago
Created attachment 315759 [details] [diff] [review]
Patch v1.1

This patch addresses the previous comments.
Attachment #315389 - Attachment is obsolete: true
Attachment #315759 - Flags: review?(gijskruitbosch+bugs)

Comment 4

10 years ago
Is it just me, or does using the nickname list, even with this patch, go on indefinitely? Is that intended behaviour? Silver, got an opinion on this one?

Comment 5

10 years ago
The code says otherwise; it'll try each nickname in the list once and only once, starting at the current nick (if in the list), or the first (otherwise).

Comment 6

10 years ago
Comment on attachment 315759 [details] [diff] [review]
Patch v1.1

Alright, then this seems OK. r=me, assuming this tested well.
Attachment #315759 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 7

10 years ago
Checked in --> FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.82]
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.