can't view page source on international sites

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: jeziorek, Assigned: nhottanscp)

Tracking

({smoketest})

Trunk
PowerPC
Mac System 9.x
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][dogfood-])

(Reporter)

Updated

19 years ago
Keywords: smoketest
(Reporter)

Comment 1

19 years ago
on mac comm. 2000-06-16-08-M17

Comment 2

19 years ago
view source issue. Reassign to jbetak
Assignee: ftang → jbetak

Comment 3

19 years ago
Spoke with ftang.  Not critical to dogfood, but will make nsbeta2+ since it is 
very difficult to debug without it. 
Whiteboard: [nsbeta2+][dogfood-]
Status: NEW → ASSIGNED
we've had a fair share of interference from other groups. Once a while view 
source would be a blank page, some other time it would not load properly etc. 
With the current i18n additions in, we should be on the safe side, at least 
when opening a new browser window within the browser (as opposed to mailnews, 
since mailnews has neither access to the core browser intance nor knowledge of 
the presently focused document charset).

OK, since the given examples work on my clean Win32 build today (06/27) I'm 
assuming that this is a) Mac-specific and b) caused by some changes introduced 
by a group other than i18n.

The only remaining issue with view source is the fact that we presently extract 
the document charset from the window in focus. If that happens to be a context 
(right-mouse) menu, we have a problem since the menu is XUL = UTF8. This needs 
to be addressed in JS in navigator.js, possibly by using the old browser 
instance or by making Cata's new state object scriptable.

Assignee: jbetak → ftang
Status: ASSIGNED → NEW

Comment 5

19 years ago
mark it as assign
Status: NEW → ASSIGNED

Comment 6

19 years ago
nhotta- please take this jbetak's bug. It's on the Mac, so you probably is the 
best person who can help. Thanks.
Assignee: ftang → nhotta
Status: ASSIGNED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

19 years ago
Cannot reproduce, used Mac commercial build 2000-06-29-08-M17/ on MacOS9.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

19 years ago
I verified this in 2000-07-10-20 Mac build.
Status: RESOLVED → VERIFIED
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.