Right-click on form (or any) button doesn't bring-up context menu and freezes the "onclick" appearance

RESOLVED DUPLICATE of bug 426074

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 426074
10 years ago
10 years ago

People

(Reporter: Natch, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041306 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041306 Minefield/3.0pre

When right-clicking a button in Firefox 2 I used to get a context menu, although minimally connected to the button, however in the latest firefox build the menu doesn't appear and the button remains frozen in the pressed position even after the mouse is unclicked, moved, etc.

At the same time I've observed a small difference in Mozilla and IE in the button rollover handling, in that IE displays the action content of the form in the statusbar, which is nice, and Mozilla does not.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox and browse to any site with a button tag.
2.Right-click on the button.
3.Observe the appearance of the button when you rollover.
Actual Results:  
The click doesn't display a context menu and the button remains "clicked".

Expected Results:  
either right-clicking is considered a valid click and the action associated should run or the right-click should have no effect on the button, (maybe only bringing-up the context menu).
(Reporter)

Updated

10 years ago
Keywords: regression
This is probably the result of Bug 404536. The depressed state of the button is Bug 426074.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426074
You need to log in before you can comment on or make changes to this bug.