Mac OS X Hide / Show toolbars button does not preserve toolbar state before hidden

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: mws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

Attachments

(1 attachment)

290 bytes, text/html
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

Windows can be opened with window.open with properties that remove parts of the toolbar like toolbar=no.

In OS X you can hide the toolbar by pressing the hide toolbars button at the top-right of the window.  You can show the toolbar again by pressing the button again, but Firefox will show the entire toolbar + bookmarks bar instead of just preserving the way the toolbar looked before it was hidden.

Reproducible: Always

Steps to Reproduce:
1. Click on a link that opens a new window that removes portions of the window toolbar
2. click the hide/show toolbar button to hide the toolbar
3. click the hide/show toolbar button again to show the toolbar
Actual Results:  
The complete toolbar appears

Expected Results:  
The toolbar appears as it was before it was hidden

Depending on how you look at it, this actually could be considered a feature.
(Reporter)

Comment 1

10 years ago
Created attachment 315438 [details]
test case

Updated

10 years ago
Duplicate of this bug: 445577

Updated

10 years ago
Duplicate of this bug: 446709
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
(Reporter)

Comment 5

8 years ago
This still exists in 3.6.10 and 3.6 nightly builds.  It does not exist in 4.0 nightly builds because the hide/show toolbar button was removed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.