FlushPendingNotifications() should only flush reflows if needed

VERIFIED FIXED in mozilla0.8

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: pollmann, Assigned: pollmann)

Tracking

({perf})

Trunk
mozilla0.8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

19 years ago
Per Johnny's note on bug 4891, we should split this up (add a parameter) into 
flushing content changes only, and flushing both content changes and reflows  We 
could then look at the callers to see who might gain performance benefits from 
only flushing content changes.
(Assignee)

Comment 1

19 years ago
I have a first pass at this done in my tree, the diff is not large.
Status: NEW → ASSIGNED
Keywords: perf
Target Milestone: --- → M18
(Assignee)

Comment 2

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M18 → Future
Set milestone to mozilla0.8
Target Milestone: Future → mozilla0.8
(Assignee)

Comment 4

18 years ago
Created attachment 24508 [details] [diff] [review]
patch (reverse)
(Assignee)

Comment 5

18 years ago
Created attachment 24512 [details] [diff] [review]
patch (ignore above)
(Assignee)

Comment 6

18 years ago
Fix checked in.  This bug can not be (easily) verified by running the program.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

18 years ago
*** Bug 52892 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.