Closed Bug 428957 Opened 13 years ago Closed 13 years ago

Group position not correct for list items and options

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: aaronlev, Assigned: aaronlev)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression)

Attachments

(1 file, 1 obsolete file)

We use object attribute and IA2::groupPosition() to provide information about a the number of items in a group of similar widgets and the item # of each.

This info is not being correctly calculated for list item and option.
Keywords: regression
Attachment #315551 - Flags: review?(surkov.alexander)
Comment on attachment 315551 [details] [diff] [review]
Get whitelists of roles correct for ::GetAttributes()


>       role == nsIAccessibleRole::ROLE_MENUITEM ||
>       role == nsIAccessibleRole::ROLE_LISTITEM ||
>+      role == nsIAccessibleRole::ROLE_OPTION ||
>+      role == nsIAccessibleRole::ROLE_RADIOBUTTON ||
>+      role == nsIAccessibleRole::ROLE_RICH_OPTION ||
>       role == nsIAccessibleRole::ROLE_OUTLINEITEM ||

that's fine.

>       content->HasAttr(kNameSpaceID_None, nsAccessibilityAtoms::aria_checked)) {
>     // Might be checkable -- checking role & ARIA attribute first is faster than getting state

>         role == nsIAccessibleRole::ROLE_PAGETAB ||
>+        role == nsIAccessibleRole::ROLE_OPTION ||
>+        role == nsIAccessibleRole::ROLE_RADIOBUTTON ||
>+        role == nsIAccessibleRole::ROLE_RICH_OPTION ||
>         role == nsIAccessibleRole::ROLE_OUTLINEITEM) &&
>         0 == (State(this) & nsIAccessibleStates::STATE_INVISIBLE)) {
>       nsCOMPtr<nsIAccessible> parent = GetParent();

I'm not sure about ROLE_RICH_OPTION because it's not used by ARIA but usually we rewrite group position calculating for certain widgets. Don't we do in this case?
Attachment #315551 - Attachment is obsolete: true
Attachment #315630 - Flags: review?(surkov.alexander)
Attachment #315551 - Flags: review?(surkov.alexander)
Comment on attachment 315630 [details] [diff] [review]
Address Surkov's comment -- we don't need RICH_LIST_OPTION because it sets these attributes in SetAccAttrsForXULSelectControlItem()

r=me
Attachment #315630 - Flags: review?(surkov.alexander)
Attachment #315630 - Flags: review+
Attachment #315630 - Flags: approval1.9?
Comment on attachment 315630 [details] [diff] [review]
Address Surkov's comment -- we don't need RICH_LIST_OPTION because it sets these attributes in SetAccAttrsForXULSelectControlItem()

a1.9=beltzner
Attachment #315630 - Flags: approval1.9? → approval1.9+
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041606 Minefield/3.0pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.