There should be pictures of the officials and small images of their districts visible.

VERIFIED DUPLICATE of bug 64488

Status

Camino Graveyard
General
--
major
VERIFIED DUPLICATE of bug 64488
10 years ago
10 years ago

People

(Reporter: sciwriter, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.13) Gecko/20080327 Camino/1.6b4 (like Firefox/2.0.0.13)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.13) Gecko/20080327 Camino/1.6b4 (like Firefox/2.0.0.13)

The images of elected officials and the small images of their districts are not visible. They are in Safari. Also, when I click on the link to go to the PDF map, I get a "page not found" error from Camino.

Oh, and despite the warning about pop-up blockers, the same thing happens when I go to Preferences and disable all the annoyance blockers: allow pop-up ads, web advertising, etc.

Reproducible: Always

Steps to Reproduce:
1.Load the page from the URL above and look at what's missing.
2.
3.
Actual Results:  
The same thing.

Expected Results:  
I should see images.

Comment 1

10 years ago
<img id="DataList1__ctl4_memberImage" src="\crepository\countyboard\images\5.jpg" alt="Karen Nelson" border="0" height="142" width="100" />

not the backslash '\' in the url, instead of a '/'

Most reports bout this are duped to bug 64488, or are made TechEvangelism.

Please complain to the webmaster. '\' is Windows file-system path separator.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 64488

Updated

10 years ago
Status: RESOLVED → VERIFIED

Comment 2

10 years ago
...and most of the webmasters like this will just ignore me or reply with something like "sorry we don't support firefox please use IE instead bye" :(

PS. Even Opera has support of the backslashes. I don't think technically this is too hard, and there are no reason why it shouldn't supported (as it won't break "correct" sites).

Comment 3

10 years ago
(In reply to comment #2)
> and there are no reason why it shouldn't supported

Yes, there is. There is an RFC fundamental to the handling of URIs that explicitly states what should happen in this case, and Gecko does that. Explicitly violating standards because emulating IE's incorrect behavior is more convenient for lazy webmasters is not the way Gecko is built, and that's not negotiable.

Please read the bugzilla etiquette before posting in bugs.

Comment 4

10 years ago
Just for Firefox users convenience you can use following bookmarklet to see the PDF documents on that site, it also fixes many other slash issues

javascript:(function(){var%20a=RegExp('%'+'5C','gi');
location=(''+location).replace(a,'\\').replace(/^[^\\]+\/\\/,'/')
.replace(/\\/g,'/').replace(/\/$/,'');})()

How to use:-
1. Create a new bookmark on bookmark toolbar
2. paste above javascript bookmarklet on "Location" entry of bookmarklet 
3. Go to PDF link 
   http://www.racineco.com/countyboard/%5Ccrepository%5Ccountyboard%5Cimages%5Clmap11.pdf
4. When page shows file not found click the new bookmarklet 

(In reply to comment #2)
> ...and most of the webmasters like this will just ignore me or reply with
> something like "sorry we don't support firefox please use IE instead bye" :(

That looks like a Government Dept website. 
They wont be able to say that.
So please do write to them

(In reply to comment #3)
> Explicitly violating standards because emulating IE's incorrect behavior is
> more convenient for lazy webmasters is not the way Gecko is built

There are many instances where we Do Violate W3C standards 
eg:- 
1. document.all support
2. as well as See link below, where IE do follow std, but we dont
http://groups.google.com/group/mozilla.dev.platform/browse_thread/thread/efbb0861ca5d0e67 
in bug 407636

A better option for fixing this kind of bugs in the web is to make authors (or corresponding QA persons) aware of the bugs on their webpage.
To do that firefox should have fixed the "DOS slash" issue in URL when it get a "HTTP 404 - File not found" error and then give a visual indication on browser status bar or something like a Pop-up waring screen


You need to log in before you can comment on or make changes to this bug.