Opacity <1 layer under or over sibling audio/mpg object layer causes object to disappear/flicker on scroll/resize

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Steven Rowat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

The quicktime controller for an embedded audio object will visually disappear completely on scrolling the window, and flicker on resize, whenever there is a layer with opacity set <1 visually sitting behind it or in front of it. This is not connected to the inheritance of opacity (so-called) because it happens with siblings, not parent-children. This bug does not happen at all with Safari with the same code. This is not related to z-indexes, becase it happens with different z-indexes set (different stack order).

Reproducible: Always

Steps to Reproduce:
1.See simple example Test page above; in summary: on a valid HTML page, place a div with an image in the background, with opacity <1 (ie., opacity: .9) and z-index: 1.
2.Next place a div with position: fixed, z-index: 2, enclosing an object tag with type="audio/mpeg".
3.View page in Firefox 2 on Mac. 
Actual Results:  
On window resize, controller flickers.
On window scroll, controller disappears.
Controller is actually there, because if clicked on (the space where it was) it will reappear.

Expected Results:  
no flicker, no disappear.

I have a report that this bug does not occur when my test page is viewed from:
Linux Ubuntu, IBM Thinkpad hardware, FireFox 2.0012.

After examining the Bugzilla reports, several are close and may have the same root - particularly:
 316905 – div over flash with opacity causes flash to disappear
**very close, and with 'resolved' (but in 3.0 branch).
and Bug 309790  Absolutely positioned block element with opacity layered over Flash causes Flash object to disappear.

Testing with FireFox beta 5 (Mac OSX) does not show the bug.

Therefore it may have been fixed as part of one of the above, in the 3 branch. However since I can't find it reported anywhere that opacity UNDER an object causes the problem, or for other than Flash objects, I thought it best to place a report here for the 2.0 branch. And maybe it can still be fixed in 2?.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 2

8 years ago
Testing the same original Test file in 3.6.1, no longer find this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.