webcals scheme not supported (i.e., for https)

VERIFIED FIXED in 0.9

Status

Calendar
Provider: ICS/WebDAV
--
enhancement
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Bernard Desruisseaux, Assigned: dbo)

Tracking

unspecified

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Lightning and Sunbird 0.8 

Lightning and Sunbird should support webcals URL (for HTTPS) the same way it supports webcal URL (for HTTP).

Reproducible: Always

Steps to Reproduce:
1. Try subscribing to a calendar with a webcals://... URL.
2.
3.
Actual Results:  
You'll get an error, or get prompted to launch Outlook 2007!


See also bug 352566.
Please clarify: Does subscribing to a calendar using webcals:// via File -> New Calendar fails?

Or does clicking a webcals:// link in your favorite browser fails to open Sunbird? -> Bug 352566.

Please also copy and paste the error message.
(Reporter)

Comment 2

10 years ago
Both fails.

When trying to subscribe to a calendar using webcals:// via File -> New Calendar
I get an "External Protocol Request" dialog box that says:

> An external application must be launched to handle webcals: links.
> 
> Requested link:
>
> webcals://cal.example.com/MyCalendar.ics
>
> Application: Microsoft Office Outlook

Sunbird and Lightning will need to first support webcals links internally (this bug), before they actually register themselves as "protocol handlers" for webcals (bug 352566).
(Assignee)

Comment 3

10 years ago
Created attachment 317519 [details] [diff] [review]
allow ics to handle webcal/webcals

I think we could fix this pretty easily in the ics provider; just did that.
Assignee: nobody → daniel.boelzle
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #317519 - Flags: review?(philipp)
OS: Windows XP → All
Hardware: PC → All
There is code to support the webcal scheme:
http://lxr.mozilla.org/seamonkey/source/calendar/base/src/calProtocolHandler.js
Why does that not work? I would rather make it work, instead of the workaround proposed in the patch.
Comment on attachment 317519 [details] [diff] [review]
allow ics to handle webcal/webcals

r=philipp

Registering webcals:// as a protocol handler can be taken care of in that other bug.
Attachment #317519 - Flags: review?(philipp) → review+
Maybe I'm confused, but if webcal works as a scheme, you don't need the translation from webcal: to http: anymore in the providers, right?
(Assignee)

Comment 7

10 years ago
Created attachment 317689 [details] [diff] [review]
adding protocol handler for webcals

I think mvl is right, implementing a protocol handler is more elegant.
Attachment #317519 - Attachment is obsolete: true
Attachment #317689 - Flags: review?(mvl)
Comment on attachment 317689 [details] [diff] [review]
adding protocol handler for webcals

r=mvl
Attachment #317689 - Flags: review?(mvl) → review+
(Assignee)

Comment 9

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9

Comment 10

10 years ago
Still does not operate, unless the site is down.  Attempting to subscribe to webcal Moon Phases Calendar.  Clicking on subscribe produces alert:
"FF doesn't know how to open this address because the protocol (webcal) is not associated with any program."

Right clicking and downloading, then attempt to install from TB extension window will not operate either -- "TB could not install the file at (Location on my hard drive) because:  Not a valid install package.-207."
(Assignee)

Comment 11

10 years ago
(In reply to comment #10)
That's bug 352566; this is about using webcal URLs in calendar creation dialog.
(In reply to comment #10)
You need to copy the URL and paste it in the New Calendar Wizard into the location field. Or choose File -> Open -> Calendar File and select the .ics file you downloaded before.

Comment 13

10 years ago
Using the New Calendar Wizard worked fine.  Thank you.  However, don't believe download is the same as subscribe -- will updates be received?

Comment 14

10 years ago
Hi,

Does this mean that we can save and publish calendars wherever https is
supported? Meaning this could be used as an alternate to webdav to securely
publish and access ics files? Will this support ability to use username and
passwords? Something like publishing the ics files to in yahoo's mail account
and then accessing from the mail account.
webcals is basically just a new name for https. Instead of an alternative to webdav, webcals/https is just webdav over ssl. Not sure if yahoo has a webdav store for email, but you can easily store a calendar on a server that supports https and webdav by just adding its url as usual.

(btw, verified, its possible to use webcals:// as a scheme)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.