KB article: Error when printing

RESOLVED INVALID

Status

support.mozilla.org
Knowledge Base Articles
RESOLVED INVALID
10 years ago
6 years ago

People

(Reporter: zzxc, Assigned: zzxc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

10 years ago
Blank pages, error messages, etc

http://kb.mozillazine.org/Problems_printing_web_pages

Comment 1

10 years ago
http://support.mozilla.com/en-US/kb/Firefox+prints+pages+incorrectly ?
(Assignee)

Comment 2

10 years ago
That article is very narrow and doesn't cover troubleshooting; I didn't see it when searching.  Some problems may result in pages not being printed, at all, for example.  It seems that general troubleshooting should be on a page named "Problems when printing" or similar, but I could improve that one create a separate "Firefox will not print" article.  Which approach would be best?

Comment 3

10 years ago
How about have http://support.mozilla.com/en-US/kb/Firefox+prints+pages+incorrectly for problems where Firefox sends something to the print but it doesn't come out properly, then have one for each specific error messages?

If you can split articles up in an understandable (to the user) way, that's usually better so that users have more concise articles dealing with their issue in particular. You can add links to the other related articles in the intro if you think that users will end up on the wrong article after a search.
(Assignee)

Updated

9 years ago
Summary: KB article: Problems when printing → KB article: Error when printing

Comment 4

9 years ago
X-Ref:
http://support.mozilla.com/tiki-view_forum_thread.php?forumId=3&comments_parentId=246359

Comment 5

9 years ago
My best success in troubleshooting printing issues on the forum was the following:
(1) Check the margin settings
(2) Go to about:config and reset print.print_printer (like in MozillaZine's article)
(3) Close Firefox, open prefs.js, delete any lines with "print." in them, save it, and re-open Firefox.

(3) might be a little much for our knowledgebase, but if we think it's OK I'll write up instructions for it. Thoughts?

Other thoughts:
* I don't think we should be troubleshooting general printing issues, so one step should be "try to print something else."
* Sometimes it Just Doesn't Work, even in Firefox 3 (see, e.g. Microsoft TechNet articles). Recommend printing in Internet Explorer and Report Broken Web Site in Firefox.

Comment 6

9 years ago
do you have to do both 2 AND 3?  What if you did 2 in safe mode?

Also for the just doesn't work case, the best workaround is often to copy into a word document.
(Assignee)

Comment 7

9 years ago
This article is only for an error message occurring when printing, so it doesn't need to address issues where the print output is wrong (eg. margins).  Clearing the "print.printer" preference works the vast majority of the time on Windows; clearing all print.* settings is needed if this doesn't work.  (These errors experienced are usually triggered by the print driver itself, so it's hard to narrow down which preference(s) are at fault.)

On Mac, corrupt system caches can affect printing by causing errors, bad output, or crashes.  If clearing the preferences per above does not work, clearing the system caches usually does.  (Firefox crashes when printing should probably be a separate article linked from this article and from Firefox+Crashes)

On Linux, error messages that only occur in Firefox are probably caused by bad preferences, although we don't have a large sampling of Linux users getting print errors.  Some users have had problems printing in all GTK applications; users blame Firefox if it is the only GTK app they use.  (A misconfigured GTK CUPS backend can cause either printers to not display or printing to fail - we could refer to Linux distribution support)

For the record, a list of all print errors is at http://mxr.mozilla.org/mozilla1.9.1/source/dom/locales/en-US/chrome/layout/printing.properties#61

Comment 8

9 years ago
Cww, I should have clarified - if (1) fixes things, stop. If (2) fixes things, stop. Obviously 3 would override 2.

I can see that we might want articles for specific error messages that happen when printing.
Matthew, any update here?

Comment 10

8 years ago
Based on Comment 7, I filed Bug 521601 for an article on general printer troubleshooting (a la Comment 5).

Comment 11

6 years ago
According to https://support.mozilla.com/en-US/kb/how-the-knowledge-base-works, article requests are no longer tracked in Bugzilla.

Reporter, if you consider your request is still applicable, post a new thread describing the content with "[Proposed] Name of the article" as title in https://support.mozilla.com/forums/knowledge-base-articles

I close this bug as invalid.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.