Vertical scrollbar overlapped by horizontal scrollbar in textarea in this case

REOPENED
Unassigned

Status

()

--
trivial
REOPENED
11 years ago
2 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Created attachment 315988 [details]
testcase

See testcase, I see the vertical scrollbar being overlapped by the horizontal scrollbar in this case.
It might be only visbible for me in this testcase, because I use 'fat' scrollbars.
(Reporter)

Comment 1

11 years ago
Created attachment 315990 [details]
testcase
Attachment #315988 - Attachment is obsolete: true
(Reporter)

Comment 2

11 years ago
Created attachment 315991 [details]
screenshot of what I see
Is this not an issue for a <div style="overflow: scroll; white-space: pre"> with the same kids if it's styled to be the size the textarea is?
(Reporter)

Comment 4

11 years ago
No, at least I couldn't reproduce it with my testing, I used:
style="overflow: scroll; white-space: pre; height: 62px; border: 2px inset black;  display: inline-block; -moz-box-sizing: border-box; width: 195px;"
to try and reflect the textarea.
Odd.  There's really nothing special about the textarea here.  I'm willing to bet this is a scrollframe issue.
(Reporter)

Comment 6

11 years ago
I probably suck at making a non-textarea testcase.
What if you do "overflow: auto"?
(Reporter)

Comment 8

11 years ago
Created attachment 316020 [details]
testcase2

Gotcha. Indeed, it's also possible with a regular div (I didn't account for the font-size which seems smaller in textareas).

I can see the bug with the first div in this testcase.
I also added some divs with smaller widths, you might be able to reproduce this bug with those (for people who have normal scrollbars).
Component: Layout: Form Controls → Layout: Block and Inline
QA Contact: layout.form-controls → layout.block-and-inline
This bug is marked with keyword regression, but I don't see any information about when it regressed.
Martijn, should we block on this? Did you see this problem in a real site?
(Reporter)

Comment 12

11 years ago
No, I didn't see this on a real site, I don't think we should block on this.

Comment 13

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID 	20160510030240

I can reproduce the issue on latest Nightly (49.0a1) using "testcase2" and having larger scrollbars (e.g 25 px). In the divs with smaller widths, the vertical scrollbar disapears.
I attached a screenshot showing the "testcase2" rendering on Nightly 49 with scrollbar having a size of 25px.

Comment 14

2 years ago
Created attachment 8751257 [details]
Nightly 49 rendering with large scrollbar.bmp
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.